Excel formule complexe

Fermé
levortex5456 - 28 juin 2021 à 09:01
yclik Messages postés 3527 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 24 février 2024 - 28 juin 2021 à 11:09
salut, je n’arrive pas à créer une formule approprier.
Contexte : je voudrais distinguer la colonne B avec une nouvelle colonne en E avec des 1 et des 2 (a ou b si pb), ou 1 est égale a 25 kilos et 2 est égale a 30 kilos. Je voudrais trouver un moyen de calculer le total de kilos en B dans 2 cellules distinctes en se basant sur la colonne E.
B35=(B20+B34)*30 comme c’est 30 kilos.
merci d’avance de votre aide.
https://mon-partage.fr/f/Qmo5kQDN/
A voir également:

2 réponses

Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 063
Modifié le 28 juin 2021 à 10:09
Bonjour,

Déjà ton fichier n'est pas un fichier Excel qui fait parti de la suite Microsoft mais un fichier Calc de la suite Open Office ou Libre Office, complètement diffèrent.
Sur ton fichier joint, si on prend comme exemple colonne B en B1 tu as 51, comment peux tu avoir 1 en E1 alors que d'après tes explications 1 est égale a 25 kilos et 2 est égale a 30 kilos

peux tu expliquer ta logique en colonne E

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
0
yclik Messages postés 3527 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 24 février 2024 1 465
28 juin 2021 à 11:09
Bonjour
A priori ce sont des colisages de pots de peinture ou enduit
donc une proposition
si colonne B <= 25 cela donne un colis
donc en B36
=SOMMEPROD(B1:B18<=25)*25+SOMMEPROD(B21:B32<=25)*25

par contre pour > 25 sans panachage entre 25 et 30
en colonne E
=SI(B1>25;ARRONDI.SUP(B1/30;0);"")

A recopier vers le bas sauf les cellules somme
et en D36
=SOMME(F1:F32)*30
0