Copie de données aprés avoir trouvé une correspondance sur un autre feuillet

Signaler
-
 Zotto -
Bonjour,

J'ai deux feuilles : la feuille 1 avec des villes et leur numéro Insee et un autre feuille Avec des villes, un numéro Insee et des coordonnées GPS.
Chacune a une colonne avec un numéro Insee correspondant à une ville mais le nombre de ligne des villes n'est pas le même sur les deux feuilles.

Je voudrais que sur la feuille 1 se recopie dans une nouvelles colonne les coordonnées GPS de la ligne qui correspond au même numéro INSEE de la seconde feuille.

Il faut que j'aille sur la feuille 2 rechercher la valeur INSEE correspondante à la valeur Insee de la feuille 1 et que lorsque la condition est remplie, l'ordinateur fasse une copie de la cellule coordonnées GPS dans la colonne qui correspond. Sauf que j'ai essayé avec la fonction recherche V et que j'y arrive pas... pourriez vous m'aider ?

Merci



Configuration: Macintosh / Safari 14.1.1

5 réponses

Messages postés
9883
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
24 juin 2021
2 141
Bonjour

Peux tu envoyer un bout de ton fichier sur cjoint.com et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

Cdlmnt
Il est là merci :-)
https://www.cjoint.com/c/KFbsOLVKRxK
Messages postés
9883
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
24 juin 2021
2 141
En O2
=SI(ESTNA(RECHERCHEV(C2;'administratif_multi(1)'!$C$2:$F$10;4;0));"";RECHERCHEV(C2;'administratif_multi(1)'!$C$2:$F$10;4;0))
https://www.cjoint.com/c/KFbtqHV6WvB

RQ. Mais où sont les n° INSEE dans la feuille administratif_multi ???

Cdlmnt
Merci je vais essayer, les insee sont en C a partir de 1409, les EPCI n'ont pas de code Insee....
Balèse la formule j'aurai jamais trouvé !!
MERCI
Messages postés
9883
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
24 juin 2021
2 141
De rien

Jettes quand même un œil sur la fonction SIERREUR (dont je ne dispose pas avec mon vieil excel 2003) qui te permettra de simplifier la formule
ça devrait donner ça
=SIERREUR(RECHERCHEV(C2;'administratif_multi(1)'!$C$2:$F$10;4;0);"")

Cdlmnt
Ok je fais ca demain !
Merci à charge d’une bière si tu passes par la Bretagne !