Je n'arrive pas à installer les paquets

Signaler
-
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
-
Bonjour

Après installation de
mariadb
,
mysql
et
apache2
, j'ai tout désinstallé, mais je arrive plus à installer aucun paquet :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet apache2 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source


/etc/apt/sources.list

#deb cdrom:[Linux Mint 20 _Ulyana_ - Release amd64 20200624]/ focal contrib main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
deb http://old-releases.ubuntu.com/ubuntu/  ulyanal main restricted universe multiverse
#deb-src http://old-releases.ubuntu.com/ubuntu/ ulyana main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ ulyana-updates main restricted universe multiverse
#deb-src http://old-releases.ubuntu.com/ubuntu/  ulyana-updates main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/  ulyana-security main restricted universe multiverse
#deb-src http://old-releases.ubuntu.com/ubuntu/  ulyana-security main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/  ulyana-backports main restricted universe multiverse
#deb-src http://old-releases.ubuntu.com/ubuntu/  ulyana-backports main restricted universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/  ulyana-proposed main restricted universe multiverse
#deb-src http://old-releases.ubuntu.com/ubuntu/ ulyana-proposed main restricted universe multiverse


Merci .

3 réponses

Messages postés
1371
Date d'inscription
lundi 21 septembre 2009
Statut
Membre
Dernière intervention
31 mai 2021
612
Bonsoir,

Dépôt principal (première ligne avec "main"), il y a une erreur avec le L en trop derrière ulyana
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120
Bonjour,

Ton fichier
/etc/apt/sources.list
me paraît extrêmement suspect et explique vraisemblablement ton problème.

Malheureusement, je ne trouve pas où est documenté la liste de ces miroirs pour mint. Sous ubuntu on la trouve facilement (e.g. via cette page) mais je ne trouve pas d'équivalent pour mint. Quelques éléments de réponse sont indiqués sur cette page mais ça reste très vague.

Tu peux essayer de faire une upgrade vers une version plus récente de mint comme expliqué sur cette page, peut-être que ça débloquera ton problème, mais sans garantie.

Je t'invite à demander sur le forum mint le contenu de
/etc/apt/sources.list
et ceux contenus dans
/etc/apt/sources.list.d/
pour la version actuelle de mint afin d'avoir une configuration de référence.

Bonne chance
Messages postés
1371
Date d'inscription
lundi 21 septembre 2009
Statut
Membre
Dernière intervention
31 mai 2021
612
Je suis sous Mint 20.1 Ulyssa (après Ulyana), mais les procédures et repères ci-dessous devraient être similaires.

A noter : les dépôts old-release ne sont pas conformes. Chez vous c'est donc sans doute un reliquat d'une mise à niveau ; toutes les les lignes devraient être commentées par #.
De plus, depuis la version 20, le fichier sources.list est sans dépôt (ou vide si vous préférez). Ils sont décrits ailleurs, uniquement dans /etc/apt/sources.list.d

En solution, je suggère plutôt d'aller dans le gestionnaire de mise à jour.

Il y a une rubrique "Maintenance" dans ce gestionnaire.
- Cliquer sur Maintenance ;
- Dans cette rubrique, cliquez sur "Purger la configuration résiduelle".

Vous pouvez peaufiner ensuite en rétablissant les dépôts officiels si ce n'est pas suffisant :
- Cliquer sur "Dépôts officiels" ;
- Dans cette rubrique, cliquez sur "Restaurer les paramètres par défaut".
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120
Bonjour Laurent,

Comme ces informations ne sont pas documentées, l'idéal pour compléter la solution proposée serait de reporter le contenu de
/etc/apt/sources.list
(vide si j'ai bien suivi) et des fichiers contenus dans
/etc/apt/sources.list.d/
. Cela permettrait de contrôler que ces fichiers sont correctement remplis une fois la procédure "normale" a été suivie.

Merci
Messages postés
1371
Date d'inscription
lundi 21 septembre 2009
Statut
Membre
Dernière intervention
31 mai 2021
612 >
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021

Je rappelle que j'utilise désormais Mint 20.1 Ulyssa, malgré ce qu'indique le contenu de /etc/apt/sources.list ci-après. De toute façon, toutes les lignes sont commentées :
#deb cdrom:[Linux Mint 20 _Ulyana_ - Release amd64 20200624]/ focal contrib main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.


Et maintenant le fichier contenant les dépôts officiels pour cette version. Il s'agit de /etc/apt/sources.list/official-package-reporitories.list :
deb [http://packages.linuxmint.com] ulyssa main upstream import backport #id:linuxmint_main

deb [http://archive.ubuntu.com/ubuntu/] focal main restricted universe multiverse
deb [http://archive.ubuntu.com/ubuntu/] focal-updates main restricted universe multiverse
deb [http://archive.ubuntu.com/ubuntu/] focal-backports main restricted universe multiverse

deb [http://security.ubuntu.com/ubuntu/] focal-security main restricted universe multiverse
deb [http://archive.canonical.com/ubuntu/] focal partner


A part le premier dépôt, propre à Mint dont on peut sans doute remplacer ulyssa par ulyana, les autres dépôts sont ceux d'ubuntu 20.04 focal fossa. Par conséquent cela devrait suffire.
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120
Merci pour ces précisions, attendons de voir ce que ça donne chez abi...