Formule à comprendre

Signaler
Messages postés
46
Date d'inscription
samedi 9 février 2013
Statut
Membre
Dernière intervention
9 juin 2021
-
Messages postés
2485
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
24 juin 2021
-
=SI(ESTERREUR(RECHERCHEV($B23; FEUIL1!$B$8:$I$30; 2; FAUX)="TRUE"); 0; RECHERCHEV($B23; FEUIL1!$B$8:$I$30; 2; FAUX))

Bonjour, est ce que quelqu’un peut m'expliquer cette formule svp j'en serai très reconnaissant

2 réponses

Messages postés
1476
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
4 juin 2021
150
Bonjour,
pour commencer, sans espaces dans la formule :
=SI(ESTERREUR(RECHERCHEV($B23;Feuil1!$B$8:$I$30;2;FAUX)="TRUE");0;RECHERCHEV($B23;Feuil1!$B$8:$I$30;2;FAUX))


SIERREUR permet de renvoyer une valeur choisie si RECHERCHEV n'est pas permissive.
Sinon, il y a la valeur à l'index 2 de la valeur trouvée en B23, avec RECHERCHEV

Google est un allié... Pour preuve :
https://support.microsoft.com/fr-fr/office/sierreur-c526fd07-caeb-47b8-8bb6-63f3e417f611
https://support.microsoft.com/fr-fr/office/fonction-recherchev-0bbc8083-26fe-4963-8ab8-93a18ad188a1
Messages postés
2485
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
24 juin 2021
1 136
Bonjour
=SI B23 n'est pas trouvé Recherchev renvoi une erreur
(ESTERREUR(RECHERCHEV($B23; FEUIL1!$B$8:$I$30; 2; FAUX)="TRUE")

Alors renvoi 0

; 0;

Sinon ( donc pas d'erreur) recherche la valeur de B23 dans FEUIL1!$B$8:$I$30

RECHERCHEV($B23; FEUIL1!$B$8:$I$30; 2; FAUX))

Dans excel il y a maintenant la fonction SIERREUR qui simplifie cette syntaxe