NB.SI et ESTNUM

Fermé
xuorel Messages postés 239 Date d'inscription samedi 24 novembre 2012 Statut Membre Dernière intervention 6 juillet 2022 - 21 avril 2021 à 19:26
eriiic Messages postés 24463 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 23 novembre 2022 - 15 juin 2021 à 16:12
Bonjour,

j'ai un tableau de 5*5
Chaque case contient du texte ou des nombre.

Je souhaite définir le nombre de cases du tableau comportant une valeur numérique.

comment m'y prendre ?

Je me disais que j'allai imbriquer un ESTNUM dans un NB.SI mais ça ne fonctionne pas.

Merci pour votre aide.

Xuo

2 réponses

eriiic Messages postés 24463 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 23 novembre 2022 7 141
21 avril 2021 à 19:55
Bonjour à tous,

ou bien :
=SOMMEPROD(--ESTNUM(A2:E6))

eric
1
Utilisateur anonyme
21 avril 2021 à 20:26
A retenir ! Je ne connaissais pas cette utilisation de sommeprod()
0
ALS35 Messages postés 950 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 26 novembre 2022 108 > Utilisateur anonyme
21 avril 2021 à 21:11
Bonjour à tous,

Et pourquoi pas tout simplement pour la plage A1:E5
=NB(A1:E5)

Cordialement
0
Utilisateur anonyme > ALS35 Messages postés 950 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 26 novembre 2022
21 avril 2021 à 21:30
En effet ! Pourquoi faire plus compliqué !
0
xuorel Messages postés 239 Date d'inscription samedi 24 novembre 2012 Statut Membre Dernière intervention 6 juillet 2022
15 juin 2021 à 13:39
Merci à tous pour vos retours.

Que signifie "--" dans :

=SOMMEPROD(--ESTNUM(A2:E6))
0
eriiic Messages postés 24463 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 23 novembre 2022 7 141 > xuorel Messages postés 239 Date d'inscription samedi 24 novembre 2012 Statut Membre Dernière intervention 6 juillet 2022
15 juin 2021 à 16:12
Oui, bonjour aussi,
Le 1er - sert à convertir les booléens VRAI/FAUX en numériques.
Le 2nd à rétablir le signe : -1 => 1
Tu pourrais tout aussi bien faire +0 ou *1
eric
0
Utilisateur anonyme
21 avril 2021 à 19:38
Bonjour,
NB.SI convient bien ! En utilisant 2 formule pour prendre en compte les nombres positifs et négatifs : =NB.SI(PLAGE;">=0")+NB.SI(PLAGE;"<0") où PLAGE est à remplacer...
0