Formule avec somme.si.ens

Signaler
Messages postés
4
Date d'inscription
lundi 22 mars 2021
Statut
Membre
Dernière intervention
25 mars 2021
-
Messages postés
25957
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 avril 2021
-
Bonjour,

Bonjour,
Svp, je voudrais faire la somme des cellules d'une colonne dans excel pourvu qu'ils remplissent 2 conditions . 1 que la cellule précédente corresponde à une donné et que la cellule d'après ne soit pas vide. Comment faire.

Exemple

A B C D E
1
2
3
dans la cellule D1, je veux mettre la réponse de la somme des donnés de la colonne C si les donnés de la colonne A ne sont pas vide et si les donnés de la colonne B corresponde à E1





Configuration: Android / Chrome 87.0.4280.101

3 réponses

Messages postés
1063
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
23 mars 2021
222
Bonjour,

Un p’tit classeur avec 10/15 données anonymisées serait mieux pour régler le soucis

Allez dans https://www.cjoint.com/
Cliquez sur "PARCOURIR" pour sélectionner le classeur
Clic le bouton "CREER LE LIEN"
Clic droit quand le lien est créé "COPIER LE LIEN"
Sur le post Clic droit "Coller".

ou dans https://mon-partage.fr/
Messages postés
4
Date d'inscription
lundi 22 mars 2021
Statut
Membre
Dernière intervention
25 mars 2021

ok merci. s'il vous plait voici le lien

https://www.cjoint.com/c/KCxi3HGxalG
Messages postés
1063
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
23 mars 2021
222
Messages postés
25957
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 avril 2021
5 872
Bonjour
un conseil si c'est possible pour ne pas avoir à enter des formule trop lourdes
pour remplir le code:
copier le champ A / coller sur E5; sélectionner le champ E et onglet DONNEES > supprimer les doublons
et donc en F5:
=SOMME.SI.ENS(C:C;A:A;E5;B:B;">0")
il sera possible avec une MFC de détecter si par la suite en A, il y a des codes non présents en E
Si toutefois vous n''admettez pas l'élimination des doublons, pour appliquer une formule en E est il possible de classer A:C selon les codes pour les regrouper, afin d'appliquer une formule?
ou alors de passer par une colonne de détection, masquée ou sur une autre feuille?
cette dernière option correspondant au fichier joint ici:
https://mon-partage.fr/f/N67wUTNS/
à vous lire
crdlmnt