Calculer le nombre de fois où apparait deux mots

Signaler
-
Messages postés
53074
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
-
Bonjour,

J'aimerais trouver une fonction dans Excel qui me permettrait de calculer le nombre de mots identiques dans deux colonnes. J'ai un tableau avec plein de noms différents et j'aimerais connaitre le nombre de "Cèdre" dans la colonne B et le nombre de "Sain" dans la colonne C, sauf que dans mon tableau j'ai d'autre mots comme "Malade" et "Pin" et je doit calculer le nombre de "Cèdre" colonne B et "Pin" colonne C et pas d'autre mot dans les deux colonne. Comment je peut faire?

Merci


Configuration: Windows / Firefox 84.0

5 réponses

Messages postés
53074
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
15 041
Bonjour.

Comme d'habitude, prière de joindre un fichier-exemple Excel.
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Il existe aussi :
1) https://mon-partage.fr/
2) https://www.transfernow.net/

Messages postés
17300
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 janvier 2021
4 429
Bonsoir,

comme cela pour Cèdre dans une plage colonne B
=NB.SI(B2:B20;"Cèdre")

par contre si le mot Cèdre est composé comme Cèdre vert
=NB.SI(B2:B20;"Cèdre*")

et si Cèdre est dans une chaine
=NB.SI(B2:B20;"*Cèdre*")

et idem pour la colonne C avec le mot souhaité
Bonsoir,

Je me suis mal exprimé...
Enfaite dans la colonne B il y a 2 types d'arbres la "Cèdre" et le "Pin" et dans la colonne C il y a l'état de l'arbre si il est "sain" ou "malade" par exemple : arbre 1: c'est un "Cèdre" (colonne B) et il est "Malade" (colonne C), l'arbre 2: c'est un "Cèdre" (colonne B) et il est "sain" (colonne C), l'arbre 3: c''est un "Pin"(colonne B) et il est "sain" (colonne C) etc... sauf qu'il y a 1000 arbres et il peut y avoir des répétitions.
La question est "calculer a l'aide d'une formule combien il y a de "Cèdres" qui sont "Sains" ?"
Donc, sur je doit calculer sur les deux types d'arbre le nombre de de "Cèdre" mais qui sont "Sains" (qui ne sont pas malades et que ne se soit pas du Pin)

Désoler de m’être mal exprimé

Merci
Messages postés
53074
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
15 041
J'attends toujours ton fichier exemple.
Je n'ai pas besoin de 1000 lignes ; une quinzaine suffira.
Messages postés
17300
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 janvier 2021
4 429
Re,

en attendant que tu répondes à (Raymond, meilleurs vœux https://www.cjoint.com/c/KAnv07PWDHc)

regarde avec cette formule pour compter les Cèdres sain
=SOMMEPROD((B2:B20="Cèdre")*(C2:C20="sain"))


Messages postés
53074
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
15 041
Merci, Michel, pour ton montage et son contenu.
Je te souhaite de poursuivre, avec sérénité et toujours la même efficacité, ton marathon sur CCM durant ce nouvel exercice.
Santé et courage !
Raymond