Calculs entre deux jours sur excel

Signaler
-
 Coucouexcel -
Bonjour,

https://www.cjoint.com/c/KAlow52nOOX

Vous trouverez ici un tableau de calculs de jours.
Je ne trouve nulle part comment calculer le nombre de jours de présences.

En effet, je dois savoir combien de jours ont été utilisés entre deux dates et les calculer entre eux.

Le tableau est plus parlant.

Mais en gros exemple :

Personne présente du 02/12/2018
au 03/09/2022

En janvier 2020 elle sera présente : 30 jours de présence.

Je dois le faire pour des dizaines de personnes donc si c'était automatisé ce serait parfait.

Bonne journée,

2 réponses

Messages postés
30588
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
15 janvier 2021
7 225
Bonjour,

Essayer en D3 :
=SI(ET($B3<=FIN.MOIS(D$2;0);$C3>=D$2);DATEDIF(MAX(D$2;$B3);MIN($C3;FIN.MOIS(D$2;0));"d")+1;0) 

à dupliquer à droite, puis les 12 mois dupliquer en bas

https://www.cjoint.com/c/KAlpRAF3CZ7

Merci beaucoup, cette formule fonctionne.