Somme de Produits sur Excel (avec condition

Fermé
Pascal29992 Messages postés 90 Date d'inscription lundi 6 novembre 2017 Statut Membre Dernière intervention 18 octobre 2022 - 6 janv. 2021 à 12:57
Pascal29992 Messages postés 90 Date d'inscription lundi 6 novembre 2017 Statut Membre Dernière intervention 18 octobre 2022 - 6 janv. 2021 à 17:02
Bonjour à tous,

Je cherche une formule me permettant de faire la somme de ces cellules


Là où c'est compliqué, c'est que j'ai parfois des valeurs en € et en $
Quand la valeur est en $, puisqu'il ne s'agit que d'un format non pris en compte par Excel, j'ai associé la conversion €/$ de la date correspondante

Donc dans l'idée, voici les idées que j'ai pour écrire ma formule, mais je n'ai pas réussi à le concrétiser :


1) Faire une somme des produits des 2 colonnes pour chaque ligne

Mais comme la plupart des cases de la deuxième colonne sont vides, ça ne marche pas.
Eventuellement, je peux rajouter la valeur "1" à la place des colonnes vides, mais ça n'est pas l'idéal


2) Faire une somme des produits des 2 colonnes avec une condition

Dans l'idée : "si prix en $, alors faire le produit ; sinon, prendre juste en compte la valeur de la première colonne"
Mais la fameuse condition s'avère encore une fois difficile, puisque dans la forme actuelle, je n'ai que des formats différents
J'aurais presque besoin de créer une troisième colonne où je mets le signe monétaire (€ ou $), sur laquelle je base ma condition


3) Faire le calcul en 2 sommes distinctes

D'une part, la somme des valeurs en €, d'autre part la somme du produit des 2 colonnes pour les valeurs en $
Mais encore une fois, je n'ai pas l'impression que je puisse écrire une condition pertinente dans la forme actuelle


Avez vous des idées à me suggérer?
Je peux fournir le template si besoin

Merci !
A voir également:

6 réponses

tontong Messages postés 2549 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 23 avril 2024 1 054
6 janv. 2021 à 16:33
Bonjour,
Ça pourrait donner =SOMMEPROD((A2:A10)*((B2:B10=0)+(B2:B10)*(B2:B10>0)))
à condition que les valeurs en $ soient bien des nombres (pas des textes) et que le change soit exprimé dans le bon sens. Attention aux salades de parenthèses.
1
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139
6 janv. 2021 à 16:47
Bonjour à tous,

Peut-être aussi comme ceci, pour e somme globale
=SOMMEPROD((A2:A10);SI(B2:B10>0;B2:B10;1))


Cordialement
1
PapyLuc51 Messages postés 4321 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 27 mai 2024 1 411
6 janv. 2021 à 14:49
Bonjour,

J'ai pas tout compris ; si tu veux les totaux en $ d'une part et en € pour le reste

pour les $

=SOMME.SI(colonne 2;">0";colonne 1)

pour les €

=SOMME(colonne 1)-le total des $

sinon envoie le fichier

Cordialement
0
The_boss_68 Messages postés 927 Date d'inscription dimanche 15 novembre 2015 Statut Membre Dernière intervention 15 mai 2024 176
6 janv. 2021 à 16:27
Bonjour,

Un essai ci-joint

Ps: activer les macros même qu'il y en à pas.... si non ça marche pas

https://www.cjoint.com/c/KAgpx6TCBbj

Slts
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Pascal29992 Messages postés 90 Date d'inscription lundi 6 novembre 2017 Statut Membre Dernière intervention 18 octobre 2022 4
6 janv. 2021 à 16:56
Waouh mais merci pour vos réponses, je ne m'attendais pas à autant de suggestions en autant de temps

Les formules de tontong et ALS35 fonctionnent parfaitement

tontong fait bien de remarquer que le change n'était pas exprimé dans le bon sens.
Si jamais il y a une formule qui prenne le change dans sa forme actuelle, je suis preneur (dans ce cas, on ne fait pas une somme de produit, mais une somme de ratios...)

Sinon, je ne vais pas pinailler plus loin, et je vais simplement remplacer le taux actuel €/$ par $/€

Merci beaucoup
0
Pascal29992 Messages postés 90 Date d'inscription lundi 6 novembre 2017 Statut Membre Dernière intervention 18 octobre 2022 4
6 janv. 2021 à 17:02
J'ai trouvé : simplement ajouter 1/ avant la grande parenthèse :

=SOMMEPROD((F2:F51)*1/((G2:G51=0)+(G2:G51)*(G2:G51>0)))
0