Problème affichage lignes tableau en html /css [Résolu]

Signaler
Messages postés
7
Date d'inscription
lundi 11 mai 2020
Statut
Membre
Dernière intervention
7 janvier 2021
-
Messages postés
7
Date d'inscription
lundi 11 mai 2020
Statut
Membre
Dernière intervention
7 janvier 2021
-
Bonsoir,

Je suis débutante en html css et j'essaye de créer des lignes sur mes tableaux mais elles ne s'affichent pas. Pourtant j'ai vérifié mon code sur w3c toujours rien quelqu'un peut m'aider svp. j'essaie de faire un momento de mes balises apprises ( les cellules avec l'espace après le < est fait exprès car je n'ai pas trouvé d'autres solutions pour ne pas que le navigateur pense que c'est une balise)


code html :
<body>
<table>
  <caption>Balise de premier niveau </caption>
   
   <tr>

  <th>Balises</th>

  <th>Description</th>

  </tr>

  <tr>
   <td>  < html> </td>
   <td>Balise principale</td>
  </tr>
  
  <tr>
   <td> < head> </td>
   <td>En-tête de la page</td>
  </tr>
  <tr>
   <td> < body> </td>
   <td> Corps de la page</td>
  </tr>
 </table>
</br>
 <table>
  <caption> Balise de tableaux</caption>
   <tr>

  <th>Balises</th>

  <th>Description</th>

  </tr>

  <tr>
   <td> < table></td>
   <td> Afficher le tableau</td>
  </tr>

  <tr> 
   <td> < caption> </td>
   <td>Titre du tableau</td>
  </tr>

  <tr>
   <td> < tr> </td>
   <td>Ligne de Tableau</td>
   
  </tr>
   
  <tr>
   <td> < th> </td>
   <td>Cellule d'en-tête</td>
   
  </tr>


  <tr>
   <td> < td> </td>
   <td>Cellule du Tableau</td>
   
  </tr>
  <tr> 
   <td> CSS</td></tr>


 </table>




</br>

 <table>
  <caption> Balise d'entête</caption>
  <tr>

  <th>Balises</th>

  <th>Description</th>

  </tr>







 </table>

</body>
</html>



CSS:

 table {
  border: 1px solid black;
  border-collapse: collapse;
  
 }
 
  
 td,th{
  border: thin solid #6495ed;
 }


EDIT : Ajout des balises de code

2 réponses

Messages postés
32448
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
13 mai 2021
3 484
Bonjour,

Pas de souci avec ton code....
(enfin, on ne sait pas comment tu "charges" ton css ... )

Mais si tu le mets comme ça, pas de souci
<!doctype html>
<html lang="en">
<head>
  <meta charset="utf-8">
  <style>
    table {
      border: 1px solid black;
      border-collapse: collapse;
    }
       
    td,th{
      border: thin solid #6495ed;
    }
   </style>
 </head>
 <body>
<table>
  <caption>Balise de premier niveau </caption>
   
   <tr>

  <th>Balises</th>

  <th>Description</th>

  </tr>

  <tr>
   <td>  < html> </td>
   <td>Balise principale</td>
  </tr>
  
  <tr>
   <td> < head> </td>
   <td>En-tête de la page</td>
  </tr>
  <tr>
   <td> < body> </td>
   <td> Corps de la page</td>
  </tr>
 </table>
</br>
 <table>
  <caption> Balise de tableaux</caption>
  <tr>
    <th>Balises</th>
    <th>Description</th>
  </tr>
  <tr>
   <td> < table></td>
   <td> Afficher le tableau</td>
  </tr>
  <tr> 
   <td> < caption> </td>
   <td>Titre du tableau</td>
  </tr>
  <tr>
   <td> < tr> </td>
   <td>
  </tr>
  </table>
</body>
</html>


Donc, soit tu as mal chargé ton fichier css ( je suppose que tu l'as mis dans un fichier à part non ? )
Soit, c'est juste un souci de cache. Il faut VIDER le cache de ton navigateur dès que tu modifies du code css ou Javascript.

Messages postés
7
Date d'inscription
lundi 11 mai 2020
Statut
Membre
Dernière intervention
7 janvier 2021

Je voudrais quand même savoir pourquoi sur un autre fichier à part cela ne marchait pas et utiliser alors la balise style ?
Messages postés
7
Date d'inscription
lundi 11 mai 2020
Statut
Membre
Dernière intervention
7 janvier 2021

Oui je l’ai mis effectivement dans un fichier à part en tout cas merci bcp ça marche du coup