Heures négatives dans excels

Fermé
Coucouexcel - 9 nov. 2020 à 16:33
eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 19 mai 2024 - 17 nov. 2020 à 12:59
Bonjour,

Dans un tableau pour les salariés je voudrais faire un calcul qui est simple lorsque ce ne sont pas des heures. Là par exemple un salarié est censé devoir faire 147 heures, cependant imaginons qu'il n'est fait que 18h...

Si le résultat est un nombre positif cela fonctionne, si le résultat est négatif... Forcément cela ne fonctionne pas... Auriez-vous une solution ?

R10 : Total heures à effectuer 147:00
R11 : Total heures effectuées 18:00
Balance du mois (+/-) : #VALEUR!

Dans la cellule balance du mois j'ai noté : =(R11-R10)

Bonne journée

9 réponses

JCB40 Messages postés 2879 Date d'inscription lundi 2 juillet 2018 Statut Membre Dernière intervention 13 mai 2024 461
9 nov. 2020 à 16:42
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement



0
Coucouexcel
10 nov. 2020 à 08:35
Bonjour, Alors voici le fichier : https://www.cjoint.com/c/JKkhHsZgYNX

Tout doit rester en horaires. Le but étant que les employés entrent leurs horaires et que tout se calcul automatiquement. Le seul soucis qu'il me reste ce sont les heures négatives dans balance du mois dans la colonne R.

Bonne journée
0
Pierr10 Messages postés 11628 Date d'inscription mardi 13 février 2018 Statut Modérateur Dernière intervention 18 mai 2024 4 909
9 nov. 2020 à 17:30
Bonjour,

Le problème est qu'Excel ne sait pas afficher les heures négatives. Quelques solutions ici :
https://www.excel-exercice.com/heures-negatives/

Pour moi le plus simple est d'afficher les heures en format décimal (format standard) :
Créez les cellules S10 = 24 * R10
et S11 = 24* R11 et donnez leur le format standard :
Vous pouvez maintenant les soustraire et le résultat est en heures au format décimal.
Exemple : (les cellules de la colonne C sont au format standard)

0
Lulu69 Messages postés 4143 Date d'inscription mercredi 17 novembre 2004 Statut Membre Dernière intervention 13 décembre 2022 726
Modifié le 9 nov. 2020 à 17:43
Bonjour,

Open office calcul très bien les heures négatives, pourquoi excel ne pourrait pas


0
Coucouexcel
10 nov. 2020 à 11:11
Bonjour,

Il faut que le fichier soit automatique...
https://www.cjoint.com/c/JKkhHsZgYNX

J'ai des dizaines de fiches de salaires à traiter.

Je ne trouve vraiment aucune solution...
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
The_boss_68 Messages postés 927 Date d'inscription dimanche 15 novembre 2015 Statut Membre Dernière intervention 15 mai 2024 176
10 nov. 2020 à 13:44
Bonjour,

en R13 tester cette formule

=SI(R10<R11;"-"&TEXTE(ABS(R10-R11);"h:mm");R10-R11)


Ou

=SI(R11<$R$10;"- "&TEXTE(-(R11-$R$10);"[h]:mm");" "&TEXTE((R11-$R$10);"[h]:mm"))


Slts
0
Coucouexcel
10 nov. 2020 à 14:25
Ah, excusez moi, mais cela ne fonctionne pas...

En fait c'est l'inverse : R11-R10

Et j'ai inversé dans vos calculs du coup, et le résultat est faux

Cela m'indique que 118-147 = 5

Savez vous ce qu'il se passe ?
0
Coucouexcel
12 nov. 2020 à 09:08
Bonjour,

Sauriez-vous du coup adapter la cellule nouvelle balance ?
=SOMME(R11;R10)-R12

Bonne journée
0
Raymond PENTIER Messages postés 58440 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 18 mai 2024 17 113 > Coucouexcel
12 nov. 2020 à 17:01
Je suis toujours perturbé quand je vois la formule =SOMME(R11;R10)-R12
alors qu'il suffit d'écrire =R10+R11-R12

Et je vois que tu n'as pas essayé de tester ma proposition #11 ...
0
Lulu69 Messages postés 4143 Date d'inscription mercredi 17 novembre 2004 Statut Membre Dernière intervention 13 décembre 2022 726 > Raymond PENTIER Messages postés 58440 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 18 mai 2024
13 nov. 2020 à 00:11
Bonjour,

Je pense que par défaut c'est bien pour la priorisation des opérations, bien entendu ceci est que mon avis.
0
Coucouexcel > Raymond PENTIER Messages postés 58440 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 18 mai 2024
13 nov. 2020 à 08:45
Bonjour,

Mais =R10+R11-R12 ne fonctionne pas, et je ne sais pas comment faire.
=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8);"[h]:mm");" "&TEXTE((R9-$R$8);"[h]:mm"))

Il faudrait que je reprenne cette formule tout en ajoutant

+R11-R12 Mais cela bug.

Oui j'ai essayé les deux formules et celle ci fonctionne.

Merci bcp.

Bonne journée
0
Coucouexcel
10 nov. 2020 à 14:18
Bonjour,

Merci beaucoup ! je ne pensais pas que je pourrais résoudre mon problème !

Merci beaucoup et bonne journée,
0
Raymond PENTIER Messages postés 58440 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 18 mai 2024 17 113
10 nov. 2020 à 16:21
Bonjour Coucouexcel.

D'habitude, on prévoit une cellule si le résultat est positif et une autre s'il est négatif.
En R13 mettre la formule =SI(R11>R10;R11-R10;0)
Insérer des cellules en Q14:R14
En R14 mettre la formule =SI(R11<R10;R10-R11;0)
Bien entendu il faudra aussi dédoubler les cellules Q12:R12 et les actuelles cellules Q15:R15 ...
0
Raymond PENTIER Messages postés 58440 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 18 mai 2024 17 113
16 nov. 2020 à 18:24
Bonjour Coucouexcel.

Tu sembles ne pas avoir adhéré à ma suggestion du post #11 ...
Je te refais malgré tout la même proposition, dans une présentation légèrement différente.

Cordialement.
0
Coucouexcel
17 nov. 2020 à 08:29
Bonjour,

Le soucis est que le moins doit apparaitre car il est retranscrit dans un autre tableau.
Avant les gens faisaient sans horaires ce qui était compliqué surtout que ce ne sont pas des spécialistes d'excel.

Il faut vraiment : -38

Il me faudrait inclure dans la formule le + R10 avec les m^mes conditions que l'autre. Sauf que je ne comprends pas assez cette formule pour pour pouvoir l'appliquer...

=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8);"[h]:mm");" "&TEXTE((R9-$R$8);"[h]:mm"))

=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8)+R10;"[h]:mm");" "&TEXTE((R9-$R$8)+R10>;"[h]:mm")) cette formule est fausse mais c'est l'idée...

Bonne journée
0
Lulu69 Messages postés 4143 Date d'inscription mercredi 17 novembre 2004 Statut Membre Dernière intervention 13 décembre 2022 726
Modifié le 9 nov. 2020 à 17:45
Autrement tu remplace les : par une ,


Le résultat est en centième d'heure

-1
eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 19 mai 2024 7 217
10 nov. 2020 à 11:04
Bonjour,

Non, pas si simple
170:00 - 15:45 = 15:15 soit 15,25 en centièmes d'heures.
eric
0