Heures négatives dans excels

Signaler
-
Messages postés
23643
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 novembre 2020
-
Bonjour,

Dans un tableau pour les salariés je voudrais faire un calcul qui est simple lorsque ce ne sont pas des heures. Là par exemple un salarié est censé devoir faire 147 heures, cependant imaginons qu'il n'est fait que 18h...

Si le résultat est un nombre positif cela fonctionne, si le résultat est négatif... Forcément cela ne fonctionne pas... Auriez-vous une solution ?

R10 : Total heures à effectuer 147:00
R11 : Total heures effectuées 18:00
Balance du mois (+/-) : #VALEUR!

Dans la cellule balance du mois j'ai noté : =(R11-R10)

Bonne journée

9 réponses

Messages postés
2126
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
16 novembre 2020
353
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : http://cjoint.com
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement




Bonjour, Alors voici le fichier : https://www.cjoint.com/c/JKkhHsZgYNX

Tout doit rester en horaires. Le but étant que les employés entrent leurs horaires et que tout se calcul automatiquement. Le seul soucis qu'il me reste ce sont les heures négatives dans balance du mois dans la colonne R.

Bonne journée
Messages postés
5543
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
17 novembre 2020
2 347
Bonjour,

Le problème est qu'Excel ne sait pas afficher les heures négatives. Quelques solutions ici :
https://www.excel-exercice.com/heures-negatives/

Pour moi le plus simple est d'afficher les heures en format décimal (format standard) :
Créez les cellules S10 = 24 * R10
et S11 = 24* R11 et donnez leur le format standard :
Vous pouvez maintenant les soustraire et le résultat est en heures au format décimal.
Exemple : (les cellules de la colonne C sont au format standard)

Messages postés
3738
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
15 novembre 2020
455
Bonjour,

Open office calcul très bien les heures négatives, pourquoi excel ne pourrait pas


Sécuriser, sauver, tenir, protéger, maîtriser.
95% des problèmes informatiques se situent entre le clavier et la chaise

Bonjour,

Il faut que le fichier soit automatique...
https://www.cjoint.com/c/JKkhHsZgYNX

J'ai des dizaines de fiches de salaires à traiter.

Je ne trouve vraiment aucune solution...
Messages postés
717
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
16 novembre 2020
115
Bonjour,

en R13 tester cette formule

=SI(R10<R11;"-"&TEXTE(ABS(R10-R11);"h:mm");R10-R11)


Ou

=SI(R11<$R$10;"- "&TEXTE(-(R11-$R$10);"[h]:mm");" "&TEXTE((R11-$R$10);"[h]:mm"))


Slts
>
Messages postés
52666
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 novembre 2020

Bonjour,

Mais =R10+R11-R12 ne fonctionne pas, et je ne sais pas comment faire.
=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8);"[h]:mm");" "&TEXTE((R9-$R$8);"[h]:mm"))

Il faudrait que je reprenne cette formule tout en ajoutant

+R11-R12 Mais cela bug.

Oui j'ai essayé les deux formules et celle ci fonctionne.

Merci bcp.

Bonne journée
Messages postés
717
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
16 novembre 2020
115 > Coucouexcel
Bonjour,

Sauriez-vous du coup adapter la cellule nouvelle balance ?
=SOMME(R11;R10)-R12


Pour info c'est quoi pour toi "la cellule nouvelle balance"

Slts
>
Messages postés
717
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
16 novembre 2020

Bonjour,

C'est la cellule en R13.
https://www.cjoint.com/c/JKqoBV61r5X

En gros, c'est la balance du mois qui s'additionne à celle du mois précédent.
Comme cela ne fonctionne pas je pense qu'il faut reprendre les calculs de la cellule du mois sauf que je ne comprends pas assez bien ces calculs pour faire la somme avec l'autre cellule...

Bonne journée,
>
Messages postés
717
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
16 novembre 2020

Bonjour,

Le soucis est que le moins doit apparaitre car il est retranscrit dans un autre tableau.
Avant les gens faisaient sans horaires ce qui était compliqué surtout que ce ne sont pas des spécialistes d'excel.

Il faut vraiment : -38

Il me faudrait inclure dans la formule le + R10 avec les m^mes conditions que l'autre. Sauf que je ne comprends pas assez cette formule pour pour pouvoir l'appliquer...

=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8);"[h]:mm");" "&TEXTE((R9-$R$8);"[h]:mm"))

=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8)+R10;"[h]:mm");" "&TEXTE((R9-$R$8)+R10>;"[h]:mm")) cette formule est fausse mais c'est l'idée...

Merci beaucoup et bonne journée
Messages postés
23643
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 novembre 2020
6 469 > Coucouexcel
Bonjour,

ce qu'il faudrait que tu arrives à admettre c'est qu'excel ne sait pas travailler avec des heures négatives. Pas la peine d'essayer de lui faire additionner -32:00 qui est du texte

Reprends ta formule en R11 que tu complètes en ajoutant R10 :
=SI(R9-$R$8+R10<0;"- "&TEXTE(-(R9-$R$8+R10);"[h]:mm");" "&TEXTE((R9-$R$8+R10);"[h]:mm"))

que j'aurais plutôt écrite ainsi :
=SI(R9-$R$8+R10<0;"- ";"")&TEXTE(ABS(R9-$R$8+R10);"[h]:mm")

eric

Bonjour,

Merci beaucoup ! je ne pensais pas que je pourrais résoudre mon problème !

Merci beaucoup et bonne journée,
Messages postés
52666
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 novembre 2020
14 590
Bonjour Coucouexcel.

D'habitude, on prévoit une cellule si le résultat est positif et une autre s'il est négatif.
En R13 mettre la formule =SI(R11>R10;R11-R10;0)
Insérer des cellules en Q14:R14
En R14 mettre la formule =SI(R11<R10;R10-R11;0)
Bien entendu il faudra aussi dédoubler les cellules Q12:R12 et les actuelles cellules Q15:R15 ...
Messages postés
52666
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 novembre 2020
14 590
Bonjour Coucouexcel.

Tu sembles ne pas avoir adhéré à ma suggestion du post #11 ...
Je te refais malgré tout la même proposition, dans une présentation légèrement différente.

Cordialement.

Bonjour,

Le soucis est que le moins doit apparaitre car il est retranscrit dans un autre tableau.
Avant les gens faisaient sans horaires ce qui était compliqué surtout que ce ne sont pas des spécialistes d'excel.

Il faut vraiment : -38

Il me faudrait inclure dans la formule le + R10 avec les m^mes conditions que l'autre. Sauf que je ne comprends pas assez cette formule pour pour pouvoir l'appliquer...

=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8);"[h]:mm");" "&TEXTE((R9-$R$8);"[h]:mm"))

=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8)+R10;"[h]:mm");" "&TEXTE((R9-$R$8)+R10>;"[h]:mm")) cette formule est fausse mais c'est l'idée...

Bonne journée
Messages postés
3738
Date d'inscription
mercredi 17 novembre 2004
Statut
Membre
Dernière intervention
15 novembre 2020
455
Autrement tu remplace les : par une ,


Le résultat est en centième d'heure

Sécuriser, sauver, tenir, protéger, maîtriser.
95% des problèmes informatiques se situent entre le clavier et la chaise
Messages postés
23643
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 novembre 2020
6 469
Bonjour,

Non, pas si simple
170:00 - 15:45 = 15:15 soit 15,25 en centièmes d'heures.
eric