Formule qui ne fonctionne que pour mes premiers critères

Fermé
Escarpins Messages postés 11 Date d'inscription samedi 15 octobre 2011 Statut Membre Dernière intervention 27 octobre 2020 - 27 oct. 2020 à 17:44
Escarpins Messages postés 11 Date d'inscription samedi 15 octobre 2011 Statut Membre Dernière intervention 27 octobre 2020 - 27 oct. 2020 à 18:15
Bonjour
je suis en train de faire une base pour des livres que je vais vendre dans une foire aux livres.
J'ai donc créé une cellule D3, recevant les codes prix (avec l'outil validation des données et liste) (108;109;110;111;AN;AP;AR;AS;AX;BA;BT;BV;CA;CC;CK;CU;DJ;DK;DL;DO;DX;EN), pour qu'en E3 apparaisse le prix.
Cela marche jusqu'à la formule : SI(D3=111;"25"; mais pour les suivantes ça ne fonctionne plus.
Il m'indique : erreur dû à un nom non valide.
Hélas mes codes prix ne sont pas que des chiffres... Pour autant, J'ai tout de même essayé d'en ajouter un au bout : SI(D3=112;"9" mais ça ne marche pas non plus.
Après moult essais, vérifications des syntaxes, espaces.... j'ai écumé le net sans succès.
Je suis donc bloquée en espérant qu'une bonne âme Excellissime me sauvera :)

=SI(D3=108;"20";SI(D3=109;"5";SI(D3=110;"3";SI(D3=111;"25";SI(D3=AN;"0,50";SI(D3=AP;"10,70";SI(D3=AR;"1";SI(D3=AS;"1,30";SI(D3=AX;"1,50";SI(D3=BA;"2";SI(D3=BT;"2,5";SI(D3=BV;"3";SI(D3=CA;"3,5";SI(D3=CC;"3,80";SI(D3=CK;"4";SI(D3=CU;"4,50";SI(D3=DJ;"5";SI(D3=DK;"5,5";SI(D3=DL;"6";SI(D3=DO;"7";SI(D3=DX;"7,5";SI(D3=EN;"8"))))))))))))))))))))))

Vous remerciant d'avance.... très très très
Bien à vous
Nathalie
A voir également:

4 réponses

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
Modifié le 27 oct. 2020 à 18:03
Bonjour
D'une part vous faites l'inverse de ce que vous avez placé dans votre formule, à savoir:
les valeurs numériques sans guillemets (sauf si ces valeurs sont dans des cellules format texte)
les codes textes entre guillemets
Mais il serait peut être plus simple de faire un tableau de référence avec par exemple:
en colonne X de X2 à X23 la liste des codes que vous placez en D3
en colonne Y, en ligne, la valeur à ressortir correspondante à chaque code
la formule en E3 serait alors:
=SIERREUR(RECHERCHEV(D3;$X$2:$Y$23;2;0);"")
si problème revenez en déposant votre modèle ici:
https://mon-partage.fr et coller ici le lien pour y accéder
crdlmnt

Escarpins Messages postés 11 Date d'inscription samedi 15 octobre 2011 Statut Membre Dernière intervention 27 octobre 2020
27 oct. 2020 à 18:15
Bonsoir
Oui j'ai essayé.. mais je ne suis pas assez calée.. je n'ai pas réussi, c'est pourquoi j'avais opté pour une solution plus simple pour moi.
En tout cas merci beaucoup. je me mets cette formule sous le coude ;)
Belle soirée à vous
0
Mazzaropi Messages postés 1985 Date d'inscription lundi 16 août 2010 Statut Contributeur Dernière intervention 24 mai 2023 70
27 oct. 2020 à 17:59
Bonjour Nathalie , Vaucluse.

La suggestion de notre Master of Excel "Vaucluse" est bien meilleure, plus structurée et professionnelle.
Escarpins Messages postés 11 Date d'inscription samedi 15 octobre 2011 Statut Membre Dernière intervention 27 octobre 2020
27 oct. 2020 à 18:15
Oui merci, mon problème est résolu
merci beaucoup
belle soirée à vous :)
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
27 oct. 2020 à 18:02
si vous le dites, toutefois si les masters d'Excel étaient seulement de mon niveau, CCM n'aurait sûrement pas le même succès! :-)) vos interventions ont tout autant de valeur.
Merci quand même et bonne route
bien cordialement
Mazzaropi Messages postés 1985 Date d'inscription lundi 16 août 2010 Statut Contributeur Dernière intervention 24 mai 2023 70
27 oct. 2020 à 17:54
Nathalie, Bonjour.

Si le code AN est du texte, vous devez le traiter comme du texte: "AN"
Seulement ça.

C'est ce que tu voulais?
J'espère avoir aidé.
Escarpins Messages postés 11 Date d'inscription samedi 15 octobre 2011 Statut Membre Dernière intervention 27 octobre 2020
27 oct. 2020 à 18:12
Ahhhh Génial !!!! Merci beaucoup !
Excel c'est magique avec des amis !
Merci beaucoup !
0