EXCEL : différents résultats possibles en fonction d'un rang

Signaler
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020
-
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020
-
Bonjour,

Dans la cellule en question je dois afficher les différents résultats en fonction d'une cellule indiquant le rang (j'ai donc déjà une colonne indiquant le rang, chaque cellule de cette colonne sera ma référence).

Concrètement :
- si rang 1 : 10000
- si rang 2 : 8000
- si rang 3 : 6000
- si rang 4 : 4000
- si rang 5 : 2000
Sinon 0

Merci d'avance pour votre aide,

Xavier


Configuration: Windows / Firefox 81.0

3 réponses

Messages postés
23674
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 novembre 2020
6 494
Bonjour à tous,

je dirais même :
=SI(A2>5;0;CHOISIR(A2;10000;8000;6000;4000;2000))

ou bien :
=MAX(0;(6-A2)*2000)

eric
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020

Merci Eric, au final la formule MAX est la plus efficace, sous réserve de la connaitre bien sûr !
Messages postés
2875
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 novembre 2020
397
Bonjour à tous,

=si(cellule de rang="";0;choisir(10000;8000;6000;4000;2000)
ou
=si.multiple(cellule de rang;1;10000;2;8000;3;6000;4;4000;5;2000;0)
suivant version excel

Crdlmt
Messages postés
24
Date d'inscription
samedi 5 mars 2011
Statut
Membre
Dernière intervention
25 novembre 2020

Bonjour,

Merci pour votre réponse mais ma version d'Excel (2016) ne trouve pas la fonction si.multiple...

D'avance merci.
Messages postés
16768
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
25 novembre 2020
9 967
Bonjour,

Ben oui, si.multiple n'est pas disponible avec 2016, mais est-ce que tu as lu toute la réponse de
DjiDji59430 ?
Ah oui, il y a une petite omission dans sa formule :
=si(cellule de rang="";0;choisir((cellule de rang;10000;8000;6000;4000;2000)

m@rina