Besoin d'aide sur une formule excel avec une plage variable d'addition

Signaler
-
Messages postés
1180
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
27 octobre 2020
-
Bonjour,

Je suis à la recherche d'une formule me permettant d'additionner en fonction d'un critère ( comme Somme.si), mais où la plage à additionner est variable.

Mon tableau se présente ainsi :

Colonne 1 : Des chiffres de 1 à 100, répété de 1 à 4 fois (ligne 1,2,3,4 =1; ligne 5,6,7,8 =2; ligne 9 =3 ; etc...)
Colonne 2 : Les montant que je cherche à additionner
Colonne 3 : la formule

Je vous remercie d'avance pour l'aide que vous pourrez m'accorder

Configuration: Windows / Firefox 81.0

2 réponses

Messages postés
9579
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 octobre 2020
1 927
Bonjour

Pas clair du tout

Envoies un bout de ton fichier sur cjoint.com et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu
1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

Cdlmnt
Tu trouvera ci-dessous le lien vers un exemple de tableau,

https://www.cjoint.com/c/JJhqkjp8i1p

Ce que je cherche c'est à obtenir la somme par catégorie mais le problème est qu'il y pas le même nombre de plage a additionner dans chaque catégorie... du coup quand je fais mon copier-glisser, ça fait des erreur comme illustré en C.
Je sens que c'est un truc tout bête, mais ça veux pas.
Messages postés
2160
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 octobre 2020
866 > Fehling28
Bonsoir
a tester
en C2
=SI(A2=A1;"";SOMMEPROD(($B$2:$B$14)*($A$2:$A$14=A2)))    
>
Messages postés
2160
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 octobre 2020

Merci beaucoup! J'ai testé et cela semble marcher! Vous venez de me faire gagner 2 jours de travail :)
Messages postés
1180
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
27 octobre 2020
117 >
Messages postés
2160
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
27 octobre 2020

Pas eu le temps de regarder, mais je vois que tu as apporté la solution yclik ;)
Messages postés
1180
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
27 octobre 2020
117
Bonjour,
en B1 : le montant qui doit être additionné en colonne A
en C1 : =SOMME.SI(A1:A9;B1)

Si en B1 il y a 2 alors en C1 le résultat sera 8

Si c'est pour le nombre de valeur 2 en colonne A :
en C1 : =NB.SI(A1:A9;B1)

Si en B1 il y a 2 alors le résultat sera 4