=@SI.CONDITIONS(B15="Quartz";RECHERCHEV(C probleme compatibilité excel

Signaler
Messages postés
4
Date d'inscription
lundi 7 septembre 2020
Statut
Membre
Dernière intervention
7 septembre 2020
-
Messages postés
4
Date d'inscription
lundi 7 septembre 2020
Statut
Membre
Dernière intervention
7 septembre 2020
-
Bonjour,

nous rencontrons un problème de fonctionnement de formule sous excel, la formule ne semble pas compatible avec excel 2013 et 2016,

=@SI.CONDITIONS(B15="Quartz";RECHERCHEV(CONCAT(C15;"_";I15;"_";J15);Data!E:I;3;FAUX);B15="Granit";RECHERCHEV(CONCAT(C15;"_";I15;"_";J15);Data!K:O3;FAUX))

merci de vos réponses

6 réponses

Messages postés
12592
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 septembre 2020
1 987
Bonjour

Oui, fonction récente
Pour versions antérieures il faut utiliser des SI imbriqués
=SI(B15="Quartz";RECHERCHEV(CONCAT(C15;"_";I15;"_";J15);Data!E:I;3;FAUX);SI(B15="Granit";RECHERCHEV(CONCAT(C15;"_";I15;"_";J15);Data!K:O;3;FAUX);""))

Cdlmnt
Via
Messages postés
4
Date d'inscription
lundi 7 septembre 2020
Statut
Membre
Dernière intervention
7 septembre 2020

Bonjour via55,

merci de cette réponse rapide, mais la formule ne fonctionne pas :-(

cdlmnt,

Ale
Messages postés
12592
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 septembre 2020
1 987
La formule est correcte cependant
Il faut voir avec ton fichier
Poste un exemple de ton fichier sur mon-partage.fr, copie le lien créé et reviens le coller ici
Messages postés
4
Date d'inscription
lundi 7 septembre 2020
Statut
Membre
Dernière intervention
7 septembre 2020

Messages postés
12592
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 septembre 2020
1 987
La fonction CONCAT n'est pas connue non plus des versions antérieures
Remplace ta formule par celle-là :
=SI(B11="Quartz";RECHERCHEV(C11&"_"&I11&"_"&J11;Data!E:I;3;FAUX);SI(B11="Granit";RECHERCHEV(C11&"_"&I11&"_"&J11;Data!K1:O32;3;FAUX)))*Data!$X$2*$Q$5

Messages postés
4
Date d'inscription
lundi 7 septembre 2020
Statut
Membre
Dernière intervention
7 septembre 2020

Merci Beaucoup,

si tu passe sur Nice je t'offre une bonne bière;-)

cdt,