Erreur 404 après installation site

Signaler
-
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020
-
Bonjour,

J'ai un souci d'erreur 404 et je suis désolé si cela fait doublon mais je n'ai pas trouvé de réponses.
Je veux installer sur mon site www.corpus-chibec.fr ce logiciel Omeka Classic.
Je suis scrupuleusement leurs méthodes: https://omeka.org/classic/docs/Installation/Installation/
J'ai un hébergement chez IONOS, j'ai bien créé ma base de données, ect... et le problème d'après IONOS viendrait du fichier .htaccess.
En effet, sans modifier le nom il affiche une erreur 500 et après le renommer il affiche 404.
Comment faire dans ce cas là s'il vous plaît?
Merci beaucoup
NB: pour installer mon site je dois taper url www.corpus-chibec.fr/corpus
Merci de votre aide

Configuration: Windows / Chrome 84.0.4147.135

5 réponses

Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020
337
Bonjour,

On pourrait plus aider en ayant le contenu du .htaccess ^^
Ok merci on fait comment pour ouvrir, lire le contenu stp? désolé je suis novice
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020
337 > Lea42590
Il peut s'ouvrir avec le Bloc-Notes.

Personnellement, j'utilise Notepad++ car il permet d'avoir "ouvrir avec Notepad++ quand tu fait un clic droit dessus et de plus il ne casse pas le codage Unix du fichier.
Merci

# Omeka .htaccess: Apache configuration file
# This file is required for Omeka to function correctly.

# --------------- #
# Error Reporting #
# --------------- #

# Uncomment the SetEnv line below to turn on detailed on-screen error
# reporting.
#
# Note: This should only be enabled for development or debugging. Keep this
# line commented for production sites.
#
# SetEnv APPLICATION_ENV development

# ------------- #
# Rewrite Rules #
# ------------- #

RewriteEngine on

# If you know mod_rewrite is enabled, but you are still getting mod_rewrite
# errors, uncomment the line below and replace "/" with your base directory.
#
# RewriteBase /

# Allow direct access to files (except PHP files)
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule !\.(php[0-9]?|phtml|phps)$ - [C]
RewriteRule .* - [L]

RewriteRule ^install/.*$ install/install.php [L]
RewriteRule ^admin/.*$ admin/index.php [L]
RewriteRule .* index.php

# -------------- #
# Access Control #
# -------------- #

# Block access to all .ini files.
<FilesMatch "\.ini$">
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from all
</IfModule>
</FilesMatch>

# --------#
# Caching #
# --------#

# Uncomment the lines below in order to enable caching of some files
# (after a finished site has gone live)
#
# <IfModule mod_expires.c>
# <FilesMatch "\.(js|ico|gif|jpg|png|css)$">
# ExpiresActive on
# ExpiresDefault "access plus 10 day"
# </FilesMatch>
# </IfModule>

# ------------ #
# PHP Settings #
# ------------ #

<IfModule mod_php5.c>
php_flag register_globals off
php_flag magic_quotes_gpc off
</IfModule>
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020
337
Je commencerai par regarder si l'extension rewrite est active sur l'hébergement.

Tu n'as supprimé aucun fichier après l'installation ?
>
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020

Je n'arrive même pas à trouver comment écrire un code php sur ionos... Snif
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020
337 > Lea42590
Tu créé le fichier depuis ton PC avec un éditeur de code ou un logiciel comme Notepad++ et tu l'upload sur ton hébergeur.
>
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020

Ok je viens de le faire et de le rajouter dans mon hébergeur. Que dois-je faire ensuite? www.corpus-chibec.fr/lea ?
Merci de ton aide
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020
337 > Lea42590
Tu fait :
www.corpus-chibec.fr/nomdufichier.php

Lefichier doit obligatoirement avoir l'extension .php
>
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020

En effet, cela fonctionne mieux. J'ai une liste impressionnante de lignes.
Dans quelle partie dois je regarder pour savoir si l'extension rewrite est active ou pas?
J'ai trouvé ça sinon...
url_rewriter.hosts aucune valeur aucune valeur
url_rewriter.tags a = href, area = href, frame = src, form = fakeentry, fieldset = a = href, area = href, frame = src, form = fakeentry, fieldset =
J'ai fais ce que tu m'as dit dans SQL et j'ai exécuter ca donne ça:
Erreur
Analyse statique :

4 erreurs trouvées lors de l'analyse.

Un nom de variable était attendu. (near "?" at position 1)
Début d'énoncé inattendu. (near "?" at position 1)
Début d'énoncé inattendu. (near "php" at position 2)
Début d'énoncé inattendu. (near "phpinfo" at position 7)
Requête SQL :

<?php phpinfo()

MySQL a répondu : Documentation

#1064 - Erreur de syntaxe près de '<?php
phpinfo()' à la ligne 1
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020
337
c'est pas une requette SQL, c'est du code PHP ^^
alors je viens de trouver la solution. Et du coup je suis obligé de rajouté /index.php dans la barre d'adresse sinon cela ne fonctionne pas avec seulement www.corpus-chibec.fr mais www.corpus-chibec.fr/index.php
Comment faire pour que le "index.php" ne soit pas obligatoire à la saisie svp?
Merci beaucoup par avance.
Messages postés
2097
Date d'inscription
mercredi 21 août 2002
Statut
Contributeur
Dernière intervention
15 octobre 2020
337
A la racine du site, il faut créer (ou éditer si il existe le fichier .htaccess et y ajouter la ligne :
DirectoryIndex index.php


Cela devrait corriger le soucis.