Gestion de stock

Signaler
-
Messages postés
25166
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 juillet 2020
-
Bonjour,



Configuration: Android / Chrome 83.0.4103.106
Un contrôleur de stock demande votre aide pour la programmation d’une fiche de stocks dans les conditions suivantes
Tenir compte du libellé des opérations avant le calcul du stock à la fin de chaque opération
Si le libelle signifie « entrée » et que la quantité est saisie dans la colonne des « entrées », le programme recalcule le Stock Finale
Si le libelle signifie « entres » et que la quantité est saisie dans la colonne des « sortie », le programme renvoie un message d’erreur
Si le libelle signifie « sortie » et que la quantité est saisie dans la colonne des « sorties », le programme recalcule le Stock Finale
Si le libelle signifie « sortie » et que la quantité est saisie dans la colonne des « entrées », le programme renvoie un message d’erreur
Un de vos collègues propose la formule ci-dessous, mais, qui contient deux erreurs

=SI(ESTVIDE(C4);"";SI(ET(GAUCHE(C4;3)="BE";D4="";E4<>"");"ERREUR";SI(ET(GAUCHE(C4;2)="BE";D4<>"";E4="");F3+(SOMME($D$4:D4) -SOMME($E$4:E4));SI(ET(GAUCHE(C4;2)="Bs";D4<>"";E4="");"ERREUR";
SI(ET(GAUCHE(C4;3)="Bs";D4="";E4<>"");F3+(SOMME($D$4:D4)-SOMME($E$4:E4));"")))))
Svp quel est l'erreur dans ce syntaxe et pourquoi..

2 réponses

Messages postés
636
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 juillet 2020
61
Bonjour,
il nous serait très utile de connaître les 2 erreurs renvoyées !

Le partage du fichier ou un screen complet avec ce que vous attendez comme résultat serait bien !

La formule est bien écrite et c'est donc pas des erreurs concernant son écriture.
Messages postés
25166
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 juillet 2020
5 350
Bonjour

Il devrait y avoir moyen de simplifier ça si vous nous donnez une liste de vos conditions, mais en l'état, si ce que vous présentez est un copier coller exact de ce que vous avez dans votre fichier (voire même déposer un modèle avec de explications ici:
http://mon-partage .fr
  • un blanc en trop derrière le premier ($D$4:D4)
  • un parenthèse de trop derrière les deux SOMME($E$4:E4)
  • vous demandez à vos premier et dernier code GAUCHE avec ;3) de vérifier l'égalité entre trois lettres extraites et deux dans le texte?


écrivez plutôt, mais sous réserve d'en savoir plus
=SI(ESTVIDE(C3);"";SI(ET(GAUCHE(C4;2)="Be";D4="";E4<>"");"ERREUR";SI(ET(GAUCHE(C4;2)="BE";D4<>"";E4="");F3+SOMME($D$4:D4)-SOMME($E$4:E4);SI(ET(GAUCHE(C4;2)="Bs";D4<>"";E4="");"ERREUR";SI(ET(GAUCHE(C4;2)="Bs";D4="";E4<>"");F3+SOMME($D$4:D4)-SOMME($E$4:E4))))))


crdlmnt