Fusion automatique

Signaler
-
 Liloj -
Bonjour,

Je vais tenter d'être le plus claire possible dans mes requêtes, j'ai 2 problème que je n'arrive pas à résoudre :-s

Le premier est que je voudrais fusionner deux cellules en fonction de leur contenus

exemple : si E11 = E12 alors les fusionner

J'ai trouvé le code suivant, cependant la macro ne se déclenche pas si la première cellule est vide et s’arrête dès qu'elle rencontre une cellule vide, j'aimerai donc trouver le moyen de lui dire d’exécuter la macro à chaque fois qu'une cellule est non vide.

A savoir que la plage est fixe de E7 à E37

Sub Test1()

  Application.DisplayAlerts = False
  i = 7
  Do While Cells(i, 6) <> ""
    m = i
    Do While Cells(i, 6) = Cells(m, 6)
      i = i + 1
    Loop
    Cells(m, 6).Resize(i - m).VerticalAlignment = xlTop
    Cells(m, 6).Resize(i - m).MergeCells = True
  Loop

End Sub



Problème 2 : j'ai un tableau avec :

En A : Date
En B : Désignations (Avec une mise en forme conditionnelle basé sur la colonne C)

Idéalement j'aimerai trouver une macro qui dit si la date A1 et identique à la date A2 alors concaténer les cellules B1 & B2 mais en gardent les couleurs de chaque cellules d'origine

=SI(A2=A1;B1&CAR(10)&B2)

Bien sur la formule ne répercute pas la mise en forme (couleur de police), de plus il peut y avoir 3 date à la suite identique....


J’espère que mes problèmes trouverons solution

Merci d'avance pour votre aide et si il faut que je fasse 2 postes différents dites le moi ;-)

2 réponses

Messages postés
1984
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
1 juillet 2020
313
Bonjour,
Un exemple de votre fichier avec explications serait le bienvenu.
Pour transmettre un fichier,
Veillez à ce qu'il n'y ait PAS DE DONNEES CONFIDENTIELLES
il faut passer par un site de pièce jointe tel que cjoint.com

Allez sur ce site : http://cjoint.com
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...
Cordialement

Alors voici mon fichier, le premier pb concerne l'onglet Mois , j'aimerai que lorsqu'une donnée est identique en colonne E, qu'elle soit fusionnée, mais ne pas fusionner les cellules vides
ex : fusionner E11 et E12

Je répéterai opération pour les colonnes F, G et I

le second pb concerne l'onglet Compet° par stade, les colonnes M:O sont mes données initiales et la colonnes R le résultat attendu, ici j'aimerai que les données des cellules que j'ai concaténés garde leur couleur qui est le résultat d'une mise en forme conditionnel

Après réflexion je pense que je vais avoir à nouveau le pb des couleur de police lorsque je vais effectuer ma recherchev dans l'onglet Mois en colonne I :S


Je n'arrive pas à palier à ces problèmes, alors merci d'avance si vous pouvez faire quelque chose pour m'aider !!!!

J’espère avoir su vous expliquer correctement mes problèmes


https://www.cjoint.com/c/JFAiGvuM8RO