Souci de calcul

Signaler
Messages postés
5
Date d'inscription
mercredi 8 avril 2020
Statut
Membre
Dernière intervention
10 avril 2020
-
Messages postés
2025
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
29 mai 2020
-
Bonjour,

J'ai un fichier avec près de 9000 lignes. Cela représente la liste des mes bandes originales de films.
Depuis un onglet "COLLECTION", ou la liste est trié par Compositeur et Titre, j'ai créé dans un autre onglet la liste des compositeurs car je voulais savoir combien de films j'avais pour tel ou tel compositeur. Ceci par rapport à une autre valeur, déterminée par une colonne ou il y a la valeur 1, 2 ou x, qui est:
1, dans la collection
2, pas encore dans la collection
x, j'ai que la musique partielle
ou encore par les valeurs s'il s'agit de CD, MP3, 45T, 33T ou ZERO.
Ma solution, provisoire pour les CD par exemple est dans la formule:

=NB.SI.ENS(COLLECTION.K2:K8863;"Alex North"; COLLECTION.E2:E8863;"CD")

Collection est l'onglet ou se trouve toute la liste, Alex North est un des compositeurs, K est la colonne avec les noms des compositeurs, E est la colonne avec les valeurs des supports précités.
Mon problème est que pour avoir les statistiques je doit recopier pour chaque compositeur (il y en a près de 800) la formule et retaper son nom à l'intérieur de la formule. Je ne sais pas faire une copie vers le bas, vu que pour certains compositeurs il y a des dizaines si pas des centaines de films (Ennio Morricione par exemple). Alors leur nom est repris pour chaque titre de film.
C'est fastidieux. J'ai essayé de trouver une formule, une fonction voire une macro sans succès.
Je voulais récupérer les noms des compositeurs, sans devoir faire la saisie.
Il fut un temps, avec une programme, on pouvait mettre une boucle, style If, Then, Else, mais dans excel ou calc, je ne sais pas comment je pourrai y arriver.

Auriez-vous une idée de comment je pourrai résoudre ce problème.
Merci d'avance pour votre temps et réponse.

Cordialement,
William
Nom supprimé Modération CCM

9 réponses

Messages postés
11178
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
16 mai 2020
635
bonjour,
"Il fut un temps": qu'est-ce qui a changé entre-temps?

supposant que ta liste ne change pas souvent, ne peux-tu pas créer une liste de compositeurs en quelques manipulations "manuelles"?
Messages postés
8172
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
29 mai 2020
1 410
Bonjour,
Si j'ai bien compris :
- onglet "COLLECTION" : liste triée par Compositeur et Titre
- un autre onglet : la liste des compositeurs

« Ma solution, provisoire pour les CD par exemple est dans la formule:
=NB.SI.ENS(COLLECTION.K2:K8863;"Alex North"; COLLECTION.E2:E8863;"CD") »

Si le nom du compositeur est colonne A du 2° onglet :
=NB.SI.ENS(COLLECTION.K2:K8863;A2; COLLECTION.E2:E8863;"CD")


Cordialement
Patrice

Personne ne peut détenir tout le savoir, c'est pour ça qu'on le partage.
Messages postés
23401
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
13 mai 2020
6 164
Bonjour,

c'est du domaine des TCD (tableaux croisés dynamiques) ça (0 formule, 0 macro).
Un lien explicatif : Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=109
C'est pour Excel mais Libre office a l'équivalent.
eric
Messages postés
8172
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
29 mai 2020
1 410
Pour Calc, les tables dynamiques équivalentes aux TCD d'Excel s'appellent aujourd'hui Tables de pilote :
L'aide ici : https://help.libreoffice.org/6.4/fr/text/scalc/guide/datapilot.html?DbPAR=CALC
Messages postés
2025
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
29 mai 2020
733
Bonsoir
un classeur avec quelques données serait souhaité
Comment déposer sur Cjoint.fr
Messages postés
2025
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
29 mai 2020
733
Bonjour
Impossible ouvir le document
en mettre un allégé avec un peu de donnée pour voir
Messages postés
2025
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
29 mai 2020
733
Bonjour
si bien compris
a mettre en C26 de la feuile composer
=SOMMEPROD(($COLLECTION.$L$2:$L$399=$A26)*($COLLECTION.$E$2:$EC$399=C$3))

A recopier avec la poignée vers le haut et bas et à droite
en H3 remplacer par 2
en I3 remplacer par 1

si vous travailler toujours avec Lbre office il serit préfarble e coller le feuille sur un nouveau document car il retse des scories execl ce qui pourrait faire planter le classeur
Messages postés
5
Date d'inscription
mercredi 8 avril 2020
Statut
Membre
Dernière intervention
10 avril 2020

Bonjour et merci de la réaction rapide.
Pas grand chose, mais je ne suis pas vraiment ) l'aise dans Calc.
Si vous avez compris mon souci, c'est surtout la répétition de la formule ou je dois près de 800 fois changer le nom du compositeur. et ce dans plusieurs colonnes!
Merci d'avance.
William
Messages postés
11178
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
16 mai 2020
635
supposant que ta liste ne change pas souvent, ne peux-tu pas éliminer les doublons d'une liste de compositeurs en quelques manipulations "manuelles"?
Messages postés
5
Date d'inscription
mercredi 8 avril 2020
Statut
Membre
Dernière intervention
10 avril 2020

Bonjour,
J'ai trouvé une solution provisoire qui me convient.
J'ai repris la formule de Patrice33740 qui est
=NB.SI.ENS(COLLECTION.K2:K8863;A2; COLLECTION.E2:E8863;"CD")

J'ai pris mon éditeur préféré (https://notepad-plus-plus.org/) et j'ai recréé la formule autant de fois que j'ai de compositeur en changeant chaque fois la valeur de A2 (de A2 à A815) en somme.
Puis, avec l'outil remplacer, j'ai enlevé les espaces.
Ensuite il m'a suffit de copie cette liste dans la colonne appropriée et ce pour chacune des colonnes ou je voulais avoir des totaux.
Un peu de copy/coller, mais ça fonctionne.

Je cherche encore le moyen de récupérer le nom du compositeur depuis l'onglet COLLECTION, dans l'onglet COMPOSERS, mais comme dans Collection, il y a parfois plusieurs compositeurs identiques, ce n'est pas si évident que cela. Pour l'instant, j'ai été obligé de faire la liste des Compositeurs de façon manuelle comme l'a suggéré yg_be.

Merci en tout cas à tous les intervenants.

Si d'emblée il y a quelqu'un qui veut m'aider à un outil de développement pour ma collection, je suis disponible aussi.
L'ideal aurait été d'avoir une application qui me permettrait de savoir à tout moment ce que j'ai dans la collection, y compris sur smartphone. Et bien sur avec des possibilités de tri et de quêtes dans tout les sens de ces termes.

Bien cordialement,
William
ps.: voici le lien vers mon fichier: https://www.cjoint.com/c/JDkhZsDonC8
Messages postés
5
Date d'inscription
mercredi 8 avril 2020
Statut
Membre
Dernière intervention
10 avril 2020

re Bonjour,

Désolé, voici ce que vous demander:
https://www.cjoint.com/c/JDkiSDke0K8