Excel transformation date sous format texte en format texte différent

Signaler
Messages postés
2
Date d'inscription
mardi 7 avril 2020
Statut
Membre
Dernière intervention
7 avril 2020
-
Messages postés
9493
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 juillet 2020
-
Bonjour,

Je cherche à transformer une case du type "2011-11-29T00:11:23" au format texte, en case du type "01/12/2015 09:26" toujours en format texte.

Auriez-vous une solution? Je galère avec Excel.
Vous remerciant par avance.
Céline

4 réponses

Messages postés
9493
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 juillet 2020
1 851
Bonjour

ta date en A2
pour résultat au format jj/mm/aaa hh:mm
B2=DATE(GAUCHE(A2;4);STXT(A2;6;2);STXT(A2;9;2))+STXT(A2;15;2)/24+DROITE(A2;2)/1440
pour résultat au format texte
C2=TEXTE(B2;"jj/mm/aaa hh:mm")

Cdlmnt
Messages postés
2
Date d'inscription
mardi 7 avril 2020
Statut
Membre
Dernière intervention
7 avril 2020

Super, merci ça marche !
Par contre je n'ai absolument pas compris ce à quoi ça correspond ! Si par hasard vous avez la possibilité de m'expliquer je vous en serai gré. Sinon, pas grave, mon problème est résolu. Un grand merci.
Bonne fin de journée
Messages postés
51872
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
13 582
Bonjour Céline.

Si tu veux manipuler des données TEXTE, la première démarche consiste à regarder la définition et la syntaxe des fonctions DATE, DROITE, GAUCHE, STXT et TEXTE.
Tu trouveras les explications, le mode d'emploi et des exemples dans l'Aide en ligne d'Excel.
Quand tu auras fait ça, et si tu as encore des hésitations, interroge-nous de nouveau.
On de donnera volontiers des éclaircissements.
Mais tout t'expliquer en détail ici, ce serait trop long pour nous et trop barbant pour toi !
Bonjour Raymond.
Merci pour ce retour. Je vais suivre votre conseil pour y voir plus clair.
Merci bien.
Bonne fin de journée.
Céline
Messages postés
9493
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 juillet 2020
1 851
Re

Pour voir les différentes étapes
https://mon-partage.fr/f/fEhXtIdP/

Cdlmnt