Identifier des correspondances de données entre 2 fichiers excel

Signaler
-
Messages postés
2026
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
30 mai 2020
-
Bonjour,

Après plusieurs recherches sur le forum, je n'ai pas trouvé la manipulation exacte à mon besoin.

Mon souhait est de pouvoir identifier d'éventuelles correspondances entre une première série de données sur une feuille (18000 références) et pour l'autre une deuxième série de données (65 000 références)
Je précise que le recoupement doit pouvoir se faire sur une donnée approchante (pas exacte) car dans l'une des 2 feuilles une case contient 2 données séparées par un caractère spécial. Il faudrait au moins que la correspondances se fasse sur la première partie.

En vous remerciant par avance de votre point de vue


Configuration: Windows / Edge 18.17763

6 réponses

Messages postés
9729
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
22 mai 2020
1 050
Bonjour,
Avec un petit exemple sur exemple que vous postez sur https://www.cjoint.com/
Se sera plus compréhensible!
voici un exemple

https://www.cjoint.com/c/JDgpb3nJrYW

J'ai besoin d'un recoupement précis sur le nom en colonne A et pas avoir toutes les réponses approchantes dans la formule...
Messages postés
470
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
20 mai 2020
20
Bonsoir,

Essaie peut-être ceci, si j'ai compris
=SI(ESTNA(RECHERCHEV("*"&A1&"*";$D$1:$D$3;1;0));"pas de correspondance";"OK")


Cordialement
Messages postés
2026
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
30 mai 2020
733
Bonsoir
A tester
en E1 à recopier vers le bas
=SI(NB.SI($A$1:$A$4;GAUCHE(D1;TROUVE("*";D1)-1))>0;"Correspondance";"")
Messages postés
9729
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
22 mai 2020
1 050
Bonjour JFE,
Merci pour le fichier, il se trouve que j'ai la même proposition que yclick (merci en passant).
Je vous remercie de votre retour
La 2ème proposition est intéressante
Vu le nombre de données que je dois balayer dans mes fichiers, je souhaiterais rendre les choses plus précises
Aussi je vous remets le fichier test en feuille 2 : est-il possible d'avoir une formule qui compare A+B avec C ?
https://www.cjoint.com/c/JDgr2gmBlEW
Messages postés
2026
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
30 mai 2020
733
Re
A tester
=SI(SOMMEPROD(($A$1:$A$4=GAUCHE(D2;TROUVE("*";D2)-1))*($B$1:$B$4=STXT(D2;TROUVE("*";D2)+1;NBCAR(D2)-(TROUVE("*";D2)+1))))>0;"correspondance";""  )


point de départ en F2
=SOMMEPROD((A1:A4="Dupond")*(B1:B4="Marc"))


reste à extraire le texte de D2 avec les fonctions de texte