Grub rescue unknown filesystem [Résolu]

Signaler
Messages postés
4
Date d'inscription
samedi 4 février 2017
Statut
Membre
Dernière intervention
1 janvier 2020
-
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020
-
Salut à tous

En voulant supprimer ubuntu de mon disque pour installer une autre distribution j'ai fait une petite boulette : j'ai formaté ma partition ubuntu en pensant que windows allait quand même boot.

Résultat je me trouve sur Grub rescue avec l'erreur unknown filesystem. J'ai regardé des tonnes de tutoriels pour m'en sortir mais rien à faire, grub ne trouve pas le fichier normal.mod

Pouvez vous m'aider svp

3 réponses

Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 460
Salut,

Puisque le but final est d'installer une autre distribution, fais-le, ça te remettra grub en place et tu pourras booter sur ton Windows.
Messages postés
4
Date d'inscription
samedi 4 février 2017
Statut
Membre
Dernière intervention
1 janvier 2020

je te tiendrais au courant demain la je me prépare pour ce soir
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 460 >
Messages postés
4
Date d'inscription
samedi 4 février 2017
Statut
Membre
Dernière intervention
1 janvier 2020

@ l'année prochaine alors… ;-)
Messages postés
4
Date d'inscription
samedi 4 février 2017
Statut
Membre
Dernière intervention
1 janvier 2020
>
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020

Rebonjour et bonne année !
J'ai installé debian et grub remarche. Merci beaucoup l'ami.

Le seul petit bémol est que lors du démarrage et de l'extinction sous debian j'ai une erreur: "ata4: COMRESET failed (errno=-32)" (il me semble aussi qu'elle était apparue lors de l'installation mais je regardais ailleurs). Le problème est que elle se produit plusieurs fois de suite puis un message "ata4: reset failed, giving up" s'affiche et c'est reparti pour 5 bonne minutes. Qu'est ce qui cause cette erreur et comment je peux la corriger, j'ai pas vraiment envie que mon ordinateur mette 10 minutes à démarrer et à s'éteindre.
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 460 >
Messages postés
4
Date d'inscription
samedi 4 février 2017
Statut
Membre
Dernière intervention
1 janvier 2020

Re- et meilleurs vœux également.

Je te laisse parcourir les nombreux posts concernant cette erreur… Bon courage.
Salut,

Commence par préciser de quoi tu disposes (LiveCD, USB d'installation) pour faire le point sur ta situation... Et marque et modèle du PC.
Messages postés
4
Date d'inscription
samedi 4 février 2017
Statut
Membre
Dernière intervention
1 janvier 2020

Salut et bonne année.
En ce moment je dispose de mon pc portable avec un dual boot w10/ubuntu (que je vais éviter de formater bien sûr), une clé usb que j'utilise souvent pour des installations d'OS.
Le pc c'est un pc qu'un proche avait monté, il contient une carte mère asrock (je ne sais plus laquelle) et un hdd 1T
Messages postés
4693
Date d'inscription
lundi 24 mai 2010
Statut
Membre
Dernière intervention
19 septembre 2020
705
Bonjour,
Utiliser "Gparted" pour convertir cette partition formatée Linux, en partition Windows !
Messages postés
4693
Date d'inscription
lundi 24 mai 2010
Statut
Membre
Dernière intervention
19 septembre 2020
705 >
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020

je parlais de récupérer la partition qui ne fonctionne plus, voilà, PAS MERCI pour les "solutions foireuses" ! pfffffffff
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 460 >
Messages postés
4693
Date d'inscription
lundi 24 mai 2010
Statut
Membre
Dernière intervention
19 septembre 2020

je parlais de récupérer la partition qui ne fonctionne plus, voilà,
Ce n'est pas la question et quand bien même il l'aurait fait, ça n'aurait servi à rien vu que Windows ne boote plus !
Messages postés
4693
Date d'inscription
lundi 24 mai 2010
Statut
Membre
Dernière intervention
19 septembre 2020
705 >
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020

il ne boot plus sur la partition "linux", normal puisque c'est pas le même format de disque dur, moi je le comprends comme çà !
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 460 >
Messages postés
4693
Date d'inscription
lundi 24 mai 2010
Statut
Membre
Dernière intervention
19 septembre 2020

Ben tu comprends mal !
Messages postés
35619
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
21 septembre 2020
5 460 >
Messages postés
4693
Date d'inscription
lundi 24 mai 2010
Statut
Membre
Dernière intervention
19 septembre 2020

Un peu de lecture : Chargeur d'amorçage