Certaines applications ne démarrent pas sur Wayland [Fermé]

Signaler
Messages postés
477
Date d'inscription
vendredi 26 janvier 2007
Statut
Membre
Dernière intervention
1 mai 2020
-
 jns55 -
Bonjour,

J'ai fait un constat, le bureau d'ubuntu par défaut Wayland ne permet pas d’exécuter certaines applications, comme :
  • le Gestionnaire de paquet Synaptic,
  • WhatsApp Desktop,
  • plank,
  • mpv player

... se lancent mais impossible de fermer l'application car la barre de bouton a disparu.

En me connectant sur ubuntu xorg, toutes les applis se lancent normalement.

Je trouve wayland plus fluide au niveau des animations graphiques par rapport à xorg.
Y a-t'il un moyen de faire fonctionner toutes applications sur wayland ? Si quelqu'un a une solution?
J'aimerais aussi comprendre la différence entre wayland et xorg?

Merci de votre attention

3 réponses

Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
6 976
Bonjour,

Xorg et Wayland sont deux couches logicielles qui permettent d'avoir un mode graphique sous linux.
  • Xorg est la couche graphique utilisée traditionnellement ces dernières années. Elle succède elle même à XFree86.
  • Wayland correspond à la couche graphique qui va remplacer à terme Xorg.


Comme Wayland est récent, tout ne marche pas encore parfaitement avec. C'est pour cela que les deux co-existent. Wayland a vu le jour car l'architecture de Xorg est de moins en moins adapté de nos jours. Si tu veux plus de détails, je t'invite à regarder cette discussion (en anglais).

Il n'y a malheureusement pas grand chose qu'on puisse faire en tant qu'utilisateur pour faire marcher des applications sous wayland. Cela dépend de la manière dont a été programmé le logiciel. La seule chose que tu peux faire, c'est remonter le bug aux équipes qui développent ces logiciels ou contribuer au développement de ces logiciels (s'ils sont open source).

Bonne chance
Messages postés
477
Date d'inscription
vendredi 26 janvier 2007
Statut
Membre
Dernière intervention
1 mai 2020
57
Merci de m'avoir éclairé sur le sujet, je pensais que j'avais un problème avec mon système. je vai donc continuer à utiliser xorg pour le moment.
Bonjour,
Voir cette page pour adapter les variables d'environnement :
https://doc.ubuntu-fr.org/wayland