Fonction CONCATENER + Type de Nombre [Fermé]

Signaler
Messages postés
26
Date d'inscription
mardi 21 mars 2017
Statut
Membre
Dernière intervention
8 mai 2020
-
Messages postés
26
Date d'inscription
mardi 21 mars 2017
Statut
Membre
Dernière intervention
8 mai 2020
-
Bonjour,

J'ai deux cellules. Une qui affiche le mois, et une autre qui affiche l'année.
A1 affiche 01
A2 affiche 2019

Lorsque j'essaye :
Option 1 : =CONTANENER(A1;"_";A2) --> Excel affiche 1_2019.
Option 2 : =A1 & "_" & A2 --> Excel affiche 1_2019.
Option 3 : =TEXTE(A1;00) & "_" & TEXTE(A2;0000) --> Excel affiche 1_2019

Or je souhaite conserver le 0. J'imagine qu'il y a quelque chose à faire dans le type de "Nombre" mais je ne sais pas quoi.
Au format "Texte" il m'affiche la formule.

Pouvez m'aider à afficher ce "0" svp ?
NB: Il faudra que celui-ci disparaisse quand j'arriverai sur les mois 10, 11, 12.

Bonne soirée.
Damien.


Configuration: Windows / Chrome 77.0.3865.120

3 réponses

Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 355
Bonjour,

Essaye comme cela

=TEXTE(A1;"00" )& "_" & A2
Messages postés
26
Date d'inscription
mardi 21 mars 2017
Statut
Membre
Dernière intervention
8 mai 2020
1
Bonjour Mike-31.

Merci pour ton retour.
J'ai testé ta méthode. Nickel. Merci.

A+
Damien
Messages postés
2884
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
22 novembre 2020
779
Bonsoir

autre version concaténation

=SI(A1<=9;"0"&A1&"_"&A2;A1&"_"&A2)

Cordialement
Messages postés
2197
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
23 novembre 2020
905
Bonjour
Une autre proposition
=DATE(A2;A1;"1") 

avec un format de date MM/AAAA