Dire à Excel que À est égale à 1

Signaler
-
Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
-
Bonsoir à tous
J’ai besoin pour mon passe temps de faire un tableau qui me ferait gagner beaucoup de temps

Je calcul des chiffres suivant des prénoms des noms et des dates de naissances

J’aurais besoin que Excel sache que A=1 B=2 C=3.......

Si quelqu’un peut m’aider
Merci d’avance

9 réponses

Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
6 351
Bonjour,

avec ton nom en A2 :
=SOMMEPROD(SIERREUR(CODE(STXT(SUBSTITUE(MAJUSCULE(A2);" ";"");LIGNE(1:30);1))-64;0)) 

Formule matricielle à valider avec Shift+Ctrl+Entrée (les 3 touches en même temps)
La formule doit s'entourer de { } si la validation est correcte.
Les espaces comptent pour 0.
Si plus de 30 lettres, changer le 30 de LIGNE(1:30)
Ne traite pas les nombres... Mettre les dates dans une autre cellule
https://www.cjoint.com/c/IIEvTquTiP7
eriv
En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
9
Date d'inscription
samedi 21 octobre 2017
Statut
Membre
Dernière intervention
27 octobre 2019

Bonjour
Merci beaucoup je vais essayer ce jour merci de votre aide
Merci beaucoup beaucoup ça fonctionne au top.
Je voudrais savoir existe t’il un moyen de faire ça :

J’arrive à un nombre de 73 et quand je suis plus haute que 33 je dois faire pour que ça devient 7+3 est ce possible ou j’en demande trop ?

Et autre question pour avoir certaine réponse je ne dois calculer sur un prénom par exemple que les voyelles ou que les consonnes est ce possible aussi ?

En tout les cas vous m’avez déjà beaucoup simplifiez la vie merci beaucoup
Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
6 351
Dernier ajout, donc tâche d'être complète.
Donc 33 reste 33, si tu as 87 il faut 8+7=15 ou 1+5=6
Messages postés
9
Date d'inscription
samedi 21 octobre 2017
Statut
Membre
Dernière intervention
27 octobre 2019
>
Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020

Oui de 1 à 33 c’est ok au dessus de 33 je ne peux pas y aller
C’est en faite pour calculer quelle pierre il faut sur un bracelet de vie
Et du coup il y a 33 pierres donc impossible d’aller au dessus
Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
6 351
Bonjour à tous,

SOMMEPROD(MOD(CODE(STXT(MAJUSCULE(A2);LIGNE(INDIRECT("1:"&NBCAR(A2)));1))-65;9)+1)

eric
Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
6 351
pas du tout, simple amateur :-)
Avec une lettre par cellule :
=SIERREUR(MOD(CODE(MAJUSCULE(A2))-65;9)+1;"")

eric
>
Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020

Merci énormément tout fonctionne à perfection merci beaucoup

Alors on va dire amateur chevronné ????
Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
6 351
Disons que quand c'est un domaine qui intéresse on progresse plus
Merci beaucoup en tout les cas mon tableau est près pour le marché de noël
Belle soirée et merci encore
Messages postés
23487
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
6 351
Merci et de même
Messages postés
373
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
8 novembre 2019
20
Bonjour,
Je ne fais pas de programmation avec Excel et VBA, mais, je te propose un algorithme de correspondance :
alphabet = "abcdefghijklmnopqrstuvwxyz"
mot = "toto"
Pour chaque lettre de mot Faire:
    somme = additionner(indice+1 de alphabet[lettre])
Fin Pour

indice+1 car généralement, le premier élément à comme valeur d'indice 0. Donc indice de a vaut 0, alors que indice+1 de a vaut bien 1.
La fonction additionner va cumuler l'addition de chaque valeur d'indice de chaque lettre du mot et le total sera stocké dans la variable somme.
Messages postés
9
Date d'inscription
samedi 21 octobre 2017
Statut
Membre
Dernière intervention
27 octobre 2019

Bonjour
Merci je vais essayer les 2 solutions on verra
Merci de votre aide
Bonjour,
Comme je ne connais rien en VBA ni en matière de formules matricielles, je ferais un petit tableau dans ce genre :
https://cjoint.com/c/IJbi6WsSAei
Les puristes d'Excel voudront bien me pardonner...
Pour les dates, je ne vois pas trop ce que vous voulez faire.
Cordialement.
Merci je pensais faire ça aussi mais ça n’ira pas il faut vraiment que Excel sache que À est égal à 1 merci
Bonjour,
Sur mon tableau, A est bien égal à = 1, et B égal à 2 etc. mais il semble que vous voulez aussi que A avec un accent (À) = 1.
Voulez vous que l'on utilise toutes les lettres accentuées ?
On peut les ajouter à la colonne AG ainsi que divers caractères spéciaux, si besoin est, avec en regard le chiffre désiré.
Pourriez vous préciser ?
Suite :
Tableau rectifié et complété avec A accentué et + de 33.
https://cjoint.com/c/IJcgjCywwJi
Cordialement.
Suite :
Et pour les dates, j'ajouterais ceci (merci Wikipédia) :
https://cjoint.com/c/IJbjzDBDyFi
Pour faciliter la saisie, allez sur Menu/Option/Modifications/Déplacer la sélection après validation/Sens : cocher Droite
Bonjour,
Je vous adresse par CJoint une variante permettant le calcul au choix selon les consonnes ou les voyelles ou les deux.
https://cjoint.com/c/IJco6PkJzKi
Ah je n’avais pas vu merci
Bonjour,
Est-ce que le tableau que je vous avais envoyé le 02/10/2019 16:59 correspondait à votre demande initiale ?
Si oui, j'essaierai trouver une solution à votre nouvelle demande. Si non, envoyez une copie de votre tableau nickel...
Bonjour et merci
C’est la solution à Éric qui avait fonctionné
Mais merci de votre réponse
Bonjour

Alors j’avais réussi à faire un tableau nikel
Mais voilà une nouvelle difficulté
En faite je dois dire que À = 1 B= 3 jusqu’à I=9
Mais le J ensuite et égale à 1 et ainsi de suite ????
Bonsoir,
Vous n'avez pas répondu à ma question du 02/10 à 8:01 relative aux lettres accentuées, comme indiqué dans votre titre et dans votre post du 01/10 à 22:11. Qu'en est-il ?
Bonjour
Non pas besoin d’accent désolé je n’avais pas vu
Merci