Excel pratique

Fermé
Signaler
Messages postés
10
Date d'inscription
mardi 26 février 2019
Statut
Membre
Dernière intervention
29 novembre 2019
-
Messages postés
1135
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
28 novembre 2021
-
Bonjour,

Disons que j'ai les groupes suivants: AH- ARP- AES- AM et que chacun pourrait apparaitre aléatoirement dans différentes cellules appartenant à une même colonne. Donc, dans la cellule C3 j'ai AH, en C5: AES, en C9: AM. Là, dans la colonne C, la lettre "A" se répète 3 fois. Est-ce possible d'avoir en C1 la somme de la fréquence de "A"? (ex: En C1 j'ai le chiffre 3 puisque dans la cellule C la lettre "A" est apparut 3fois. Donc C1: 4 ou 5 si la lettre "A" apparaît 4 ou 5 fois)

Merci
A voir également:

2 réponses

Messages postés
1135
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
28 novembre 2021
255
Bonjour,

Teste cette formule en C1 (la plage est fixée jusqu'à 20 pour l'exemple)
=NB.SI(C2:C20;"A*")
Merci, c'est trop fort. Je gagne beaucoup de temps à présent. Grand merci
Messages postés
10
Date d'inscription
mardi 26 février 2019
Statut
Membre
Dernière intervention
29 novembre 2019

On garde le même principe mais cette fois c'est avec une couleur. Donc au lieu d'une lettre, à chaque fois qu'une couleur apparaît dans la cellule, le chiffre 1 s'ajoute. Ainsi, s'il y a par exemple 5 rouge dans la colonne C, dans C1 le nombre 5 (somme de la fréquence de la couleur)
Merci
Messages postés
1135
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
28 novembre 2021
255
Bonjour,

Avec deux fonction perso, à voir
https://mon-partage.fr/f/4XxchhHI/