Formule imbrigué excel

Fermé
TOURILLE1 Messages postés 10 Date d'inscription dimanche 28 avril 2013 Statut Membre Dernière intervention 28 janvier 2023 - 3 déc. 2018 à 23:01
Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 - 5 déc. 2018 à 14:42
Bonjour,
Dans la cellule E26, je voudrai mettre une formule :
SI(D23="M";C25-E23) ou SI(D23="P";ARRONDI INF.(C25*F23))
Faisant référence à la cellule D23
Dans la Cellule D23 code M = E42 et le code P = cellule F42

fichier lien
https://www.cjoint.com/c/HLdvXLvfH8L

merci de votre aide

2 réponses

Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 136
Modifié le 3 déc. 2018 à 23:40
Bonjour.

SI(D23="M";C25-E23) ou SI(D23="P";ARRONDI INF.(C25*F23)) est presque bon ...
=SI(D23="M";C25-E23;SI(D23="P";ARRONDI INF.(C25*F23);"taper M ou P"))

... et tu devrais ajouter une règle de validation de données (liste déroulante de cellule) en D23 !

0
TOURILLE1 Messages postés 10 Date d'inscription dimanche 28 avril 2013 Statut Membre Dernière intervention 28 janvier 2023
4 déc. 2018 à 00:24
avec le code P ça ne fonctionne pas le resultat est NOM?
j'ai creer une liste deroulante en D23
0
Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 136
4 déc. 2018 à 00:33
Tu as fait une erreur quelque part, parce que la formule fonctionne parfaitement !
0
eriiic Messages postés 24584 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 18 juin 2024 7 225
4 déc. 2018 à 01:44
Bonjour,

Il manque un point :
ARRONDI.INF
eric
0
Raymond PENTIER Messages postés 58506 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 136
5 déc. 2018 à 14:42
Absolument ! Le point s'est égaré à un mauvais endroit ...
Amitiés.
0