Problème de format d'affichage d'une cellule [Fermé]

Signaler
Messages postés
15
Date d'inscription
lundi 1 septembre 2014
Statut
Membre
Dernière intervention
10 avril 2020
-
Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
-
Bonjour,

Je me permets de venir vers vous pour savoir comment résoudre mon problème !
J'ai plusieurs cellules qui me permettent de convertir des minutes en heures et avec une formule l'indication "-" s'affiche lorsque le nombre d'heure est en débit. Pour ça pas de problème. Sauf que j'ai appliqué la même formule pour les heures de mes 5 agents et il y en a un qui ne s'affiche pas correctement. J'ai revu le format d'affichage tout est identique, je ne comprends pas !
CB 0:57
CBU -1:53,0000000000001 => alors que cela devrait m'afficher -1:53
EB -6:39
FLA 0:0
SMH -7:25

La formule saisit dans les cellules est
=-ENT(ABS(R33/60)) & ":" & MOD(ABS(R33);60)

Mon format de cellule est en Standard pour les 5 il n'y a que celle-ci qui déconne ! Ma cellule R33 à laquelle je me réfère est en format Nombre comme pour les autres cellules des autres agents.

Pouvez-vous m'aider pour que cela m'indique uniquement -1:53

Avec mes remerciements

Bonne journée

2 réponses

Messages postés
418
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
21 mai 2019
61
Bonjour,
Le problème vient peut-être de la valeur en R33.
pouvez vous déposer un modèle (en bidonnant les infos confidentielles ici) via un site de partage type cjoint.com ?
Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 344
Bonjour
excel à quelque fois des problèmes de conversion selon l'origine de vos données
essayez de complèter votre formule avec:
=-ENT(ABS(R33/60)) & ":" & ARRONDI(MOD(ABS(R33);60);6)
crdlmnt