Google Sheet : formule somme + date

[Résolu/Fermé]
Signaler
-
 Nico -
Bonjour à tous,

Je cherche la bonne formule pour faire une opération : je voudrais pouvoir faire la somme des quantités uniquement des dates antérieures à la date d'aujourd'hui (dans ma cellule XXX ci dessous)

Un aperçu de mon tableau :
Ligne 1 : Item / Stock à date / date 1 / date 2 / date 3 / etc...
Ligne 2 : Item 1 / XXX / quantité 1 / quantité 2 / quantité 3 / etc..
Ligne : Item 2 / XXX / quantité 4 / quantité 5 / etc....

Merci beaucoup,
Camille

1 réponse

Messages postés
3431
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 septembre 2021
977
Bonjour

avec les dates de C1 à E1
les quantités de C2 à E2

En B2

=SOMMEPROD((C$1:E$1<AUJOURDHUI())*(C2:E2))

Cordialement
2
Merci

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez Comment Ça Marche

CCM 42854 internautes nous ont dit merci ce mois-ci

Merci beaucoup !
Bonne soirée
Messages postés
3431
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
15 septembre 2021
977 > CamilleJ
Bonjour
De rien ; ma réponse semble avoir solutionné ton problème ; alors passe le sujet en résolu ===> voir ici.

Cordialement
Merci, cette formule m'a également aidé à construire un indicateur qui comptabilise des infos à partir d'une date précisée ( en remplaçant "aujourd'hui " par ma cellule.