Somme d'un nombre variable de cellule

Fermé
guerando
Messages postés
333
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
16 mai 2022
- 3 mai 2018 à 14:25
guerando
Messages postés
333
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
16 mai 2022
- 8 mai 2018 à 16:15
Bonjour,

est il possible de demander a excel d'additionner que les x premieres sommes, sachant que "x" est dans une cellule hors du tableau et qu'il va changer ?
merci d'avance,


2 réponses

DjiDji59430
Messages postés
3541
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 mai 2022
532
3 mai 2018 à 14:34
Bonjour,

la premiere cellule est en B1
=somme(decaler$B$1;0;0;$C$1;1)

x est dans c1 si c1=3 tu as =somme (b1:b3)

Cdlmnt
1
guerando
Messages postés
333
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
16 mai 2022
5
3 mai 2018 à 15:15
bonjour djidji59430,
merci pour la formule, je viens de la mettre mais ca ne fonctionne pas, j'ai fait un copier coller de la formule que tu as mis, (je l'ai mis sans le = pour le fichier joint car le fichier ne l'accepte pas)
https://www.cjoint.com/c/HEdniQVjlOc
que dois je modifier svp ?
Et pourriez vous m'expliquer la syntaxe de cette formule s'il vous plais afin que je puisse m'en servir dans d'autres cas ? merci d'avance :)
0
Mike-31
Messages postés
17941
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 mai 2022
4 940
3 mai 2018 à 15:38
Bonjour,

il manque simplement deux parenthèses, certainement une erreur involontaire de DjiDji en la recopiant

=SOMME(DECALER($B$1;0;0;$C$1;1) )
0
DjiDji59430
Messages postés
3541
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 mai 2022
532
3 mai 2018 à 16:23
Bonjour Mike-31;
Mille excuses à Guérando.
0
guerando
Messages postés
333
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
16 mai 2022
5
3 mai 2018 à 18:41
t'as pas à t'escuser, :) merci bcp !!
et merci aussi à Mike :)
0
guerando
Messages postés
333
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
16 mai 2022
5
Modifié le 3 mai 2018 à 18:45
Ca marche super !!! merci beaucoup
vous pouvez me dire comment cela se lit cette jolie formule ? merci d'avance
0
guerando
Messages postés
333
Date d'inscription
mercredi 31 mars 2010
Statut
Membre
Dernière intervention
16 mai 2022
5
3 mai 2018 à 19:05
je viens de trouver la syntaxe : ref; lignes;colonne; hauteur mais je ne comprend pas comment ca marche, par exemple comment lui dire que la somme se fait à l'horizontale ou à la verticale...
0
DjiDji59430
Messages postés
3541
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 mai 2022
532
4 mai 2018 à 00:04
syntaxe : ref; lignes;colonne; hauteur;largeur
s'il y a 1 cellule de hauteur et 5 de largeur, tu as une plage de 5 horizontale (ligne)
s'il y a 5 cellules de hauteur et 1de largeur, tu as une plage de 5 verticale (colonne)
Cdlmnt
0