Mise en forme SOMME.SI [Fermé]

Signaler
Messages postés
90
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
1 novembre 2019
-
 JL00700 -
Bonsoir,
J’ai un document composé de 2 feuilles (Base et Tableau_bord).
La Base enregistre différentes informations dont un montant en colonne H, un Type d’opération (Dépense – Recette) colonne B et une date mm/aaaa colonne L
L’alimentation de ma base se fait automatiquement à partir d’un formulaire et par insertion ligne (ligne 7).
Dans Tableau_Bord je souhaite afficher la somme des dépenses d’où la formule suivante :
=SOMME.SI.ENS(Base!H7:H14;Base!B7:B14;"Dépense")
Toutefois cette solution ne répond pas aux attentes car elle ne prend pas en compte l’évolution de la Base !!!!!
D’autre part, dans Tableau_Bord j’ai la date du jour AUJOURDHUI() qui s’affiche (H2) et il m’est demandé de faire en sorte que la synthèse ne prenne en compte que les opérations relatives au mois et an de aujourd’hui.
Je n’arrive pas mettre en œuvre ces fonctionnalité… pouvez-vous me venir en aide ?
Je vous remercie par avance de votre attention.
Cordialement
JL00700


4 réponses

Messages postés
2872
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
23 novembre 2020
397
Bonjour,

Convertis ta base en tableau (exemple =SOMME.SI(Tableau1[critére];"a";Tableau1[montant]), les plages sont dynamiques.
Puis tu utilises un tcd avec une chronologie.

Autrement, il est plus facile de travailler a partit d'un fichier .......

Cdlmnt
Re,
Cela me parait bien compliqué !
Je vais essayé de déchiffrer et mettre en œuvre mais vu mon niveau de connaissance Excel !!!
Encore merci
Cdlt
Messages postés
2872
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
23 novembre 2020
397
Tu selectionnes ta plage puis inserer==>tableau
et tu reposes ta formule et quand tu vas selectionner Base!H7:H1, ça va se transformer en Tableau1[montant] automatiquement.
tu vas avoir comme formule

=SOMME.SI.ENS(Tableau1[montant]);Tableau1["intitulé de la colonne B"];"Dépense") :

Tu fais l'experience :si tu ajoutes une ligne a ton tableau, celle ci sera prise en compte.

Tu as quelle version d'excel ?
Tu ne peux pas mettre ton fichier ?
Messages postés
12858
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 novembre 2020
2 071
Bonjour à vous deux

Un exemple par formules sans tableau ni TCD :
https://www.cjoint.com/c/HCdoU3ykZHf

Cdlmnt
Via
Messages postés
6
Date d'inscription
samedi 6 août 2011
Statut
Membre
Dernière intervention
3 mars 2018

bonjour je souhaiterais adapter cette formule sur deux arguments et en ligne. je poste mon essai. je souhaiterais automatiser la formule pour ne pas faire plus cellule chaque mois.https://www.cjoint.com/c/HCdrav8Dwec

en fevrier je souhaite avoir la somme par ligne : janvier plus fevrier / en mars somme de janv. fev.mars. etc et par ligne
Messages postés
12858
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 novembre 2020
2 071
Bonjour pivoine verte

Dans ton cas il vaut mieux utiliser SOMMEPROD
https://www.cjoint.com/c/HCdsdHU0wZf

Cdlmnt
Via
Bonsoir Via55, DjiDji,
Désolé de répondre tardivement, je suis chez les enfants (garder les loulous). Je testerais dès mon retour semaine prochaine.
La proposition de Via complète parfaitement ce que j'avais déjà réalisé... mais je vais explorer la fonction TCD.
Merci à vous de votre attention. Je vous tiens au courant dès mon retour.
Amicalement
jl00700
Bonjour Via55, Djiji,
Ca y est, de retour et quelques tests plus tard ...
J'ai essayé de transposer la formule mais probablement pas convenablement car pas de
résultat mais peut-être ai-je mal interprété le mode d'emploi que tu m'as communiqué VIA55 !
Je joins le lien de ce que j'ai opéré ce qui te permettra d'appréhender au mieux mon problème.
Encore merci à la communauté car petit à petit j'ai réellement le sentiment de progresser même si parfois il y a encore qq échecs.
Amicalement
jl00700

https://www.cjoint.com/c/HCkoANGjwq1
Messages postés
12858
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 novembre 2020
2 071
Bonsoir JL

Oui tu n'as pas transposé la formule correctement puisque tu emploies un Dat_ope qui sort de je ne saais pas où au lieu de la fonction Excel DATEVAL (qui transforme une expression texte en date)
La formule qui fonctionne en F17 serait :
=SOMME.SI.ENS(Base!H2:H2495;Base!F2:F2495;"CDD";Base!A2:A2495;">="&DATEVAL("01/"&MOIS(Tableau_Bord!H5)&"/"&ANNEE(Tableau_Bord!H5));Base!A2:A2495;"<"&DATEVAL("01/"&MOIS(Tableau_Bord!H5)+1&"/"&ANNEE(Tableau_Bord!H5)))

Cdlmnt
Via
Bonjour Via,
Effectivement, cela marche mieux comme cela.
Je n'ai pas percuté sur le fait que DATVAL était une fonction de la formule et non pas une référence de mon tableau.
Merci une fois encore pour ta générosité et ton esprit de partage.
Cordialement
JL00700