Excel multiples conditions [Fermé]

Signaler
Messages postés
1
Date d'inscription
lundi 5 février 2018
Statut
Membre
Dernière intervention
5 février 2018
-
Messages postés
25954
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
-
Bonjour,

Je cherche une formule afin de traiter mes données Excel.
Je vous illustre les données que j'ai avec l'image ci-dessous:



J'ai une règle qui dit que si une personne, par exemple Julie, a passé un examen (1er condition, colonne "Exam Result") de niveau 1 puis 2 ( 2e condition, colonne" Exam Subject") alors elle est certifiée.
Dans le cas où cette personne est bien certifiée j'aurais alors voulu que la formule m'affiche "1" point, sinon "0".

Etant donné que ces conditions s'étandent sur plusieurs lignes et colonnes je ne sais pas comment m'y prendre.

Si quelqu'un peut m'aider, je l'en remercie par avance !

A voir également:

2 réponses

Messages postés
374
Date d'inscription
jeudi 11 août 2016
Statut
Membre
Dernière intervention
13 janvier 2020
14
Bonjour lililala31,
Si tu arrive à mettre des formules sur une image tu es très forte.
Messages postés
25954
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
5 867
Bonjour


une formule pour tenter, mais ça reste dans la vague vu la qualité de vos données (surtout avec une image déjà filtrée!!!)

en supposant que le tableau commence en colonne A, la formule en ligne avec les noms:

=SI(OU(NB.SI.ENS(B:B;B2;C:C;"*niveau 2*";D:D;"pass");NB.SI.ENS(B:B;B2;C:C;"level 2*";D:D;"pass"));"certifié""non")

qui vous renverra certifié si le niveau 2 , ou level 2 est passé sur chaque ligne où se trouve le nom
(en supposant que ces textes sont respectés)

vous pouvez aussi utiliser ça dans une second tableau, avec seulement la liste des noms, ou encore afficher uniquement le résultat sur la dernière ligne ou apparaît le nom en complétant comme suit:

=SI(NB.SI($B$2:B2;B2)<NB.SI(B:B;B2);"";SI(OU(NB.SI.ENS(B:B;B2;C:C;"*niveau 2*";D:D;"pass");NB.SI.ENS(B:B;B2;C:C;"level 2*";D:D;"pass"));"certifié";"non"))


attention aux signes veillez bien aux $ et " et *

et enfin, il est possible d'augmenter le nombre de textes de détection (niveau 2 ou level 2) avec une autre formule, mais pour ça il faut en savoir plus sur vos données

vous pouvez déposer un modèle avec des noms bidonnés si besoin ici:


http://mon-partage.fr

et revenir coller le lien créé sur le site

crdlmnt