Calcul moyenne en intégrant les zéro mais pas les cases vides

Fermé
Signaler
Messages postés
11
Date d'inscription
jeudi 18 juillet 2013
Statut
Membre
Dernière intervention
13 janvier 2019
-
Messages postés
11
Date d'inscription
jeudi 18 juillet 2013
Statut
Membre
Dernière intervention
13 janvier 2019
-
Bonsoir à tous

au boulot, j'ai créé un tableau pour récupérer des données afin de les faire monter régulièrement à la direction. (voir l'exemple ci-dessous)
Pour la moyenne annuelle, jusqu'à présent, j'avais mis la formule suivante :
=SIERREUR(MOYENNE.SI(c:n;"<>0");"0") afin de ne pas prendre en considération dans le diviseur les mois où nous avions pas encore de résultats

Mais voilà, pour la première année, depuis longtemps, j'ai des mois où les résultats sont nuls.
Ce qui est génial car c'est notre but mais cela "fout en l'air" mes moyennes annuelles.

Pour cette année, j'ai fait au plus vite en modifiant la formule : j'ai mis "moyenne(c:n)

Mais quelqu'un aurait-il une formule qui me permettrait d'intégrer les mois à zéro sans que le diviseur intègre les cases vides.

Ex pour l'activité 1 = actuellement ma moyenne est de 30.34 Jours
Mais si je remplace par 0.00 J les résultats de septembre, ma formule me donne la moyenne de 30,55J (336.05/11) alors que je devrait avoir 28.00J (336,05/12) puisque j'ai des résultats pour les 12 mois.

J'ai essayé de détoper "afficher un zéro dans les cellules qui ont une valeur nulle" mais cela ne sert à rien car j'ai mis en forme les différentes cellules

Merci à tous pour votre aide

Bénédicte

https://mon-partage.fr/f/BHwlgGXy/

2 réponses

Messages postés
55048
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
16 989
Bonjour.

Tu te compliques la vie inutilement :
Excel sait faire la différence entre une valeur zéro et une cellule vide.
En O3 saisir la formule =MOYENNE(C3:N3) ; elle affiche 30,34
En N3 mettre 0 au lieu de 27,98 ; le résultat devient 28,00
Supprimer toute valeur en N3 ; le résultat devient 30,55
Messages postés
11
Date d'inscription
jeudi 18 juillet 2013
Statut
Membre
Dernière intervention
13 janvier 2019
2
Désolé de vous répondre aussi tardivement.

Merci encore pour cette réponse aussi rapide et aussi simple.