Vidéo sur une page HTML [Résolu/Fermé]

Signaler
Messages postés
262
Date d'inscription
mardi 10 novembre 2015
Statut
Membre
Dernière intervention
6 septembre 2020
-
Messages postés
262
Date d'inscription
mardi 10 novembre 2015
Statut
Membre
Dernière intervention
6 septembre 2020
-
Bonjour,
J'ai codé dans ma page html ce qui suit:
<video width="320" height="240" autoplay>
     <source src="diamant.mp4" type="video/mp4">
</video>

A l'affichage, je n'ai rien. Quand j'affiche le code source, il me dit qu'il ne trouve pas la vidéo.
Merci pour votre aide

4 réponses

Messages postés
6049
Date d'inscription
mercredi 19 janvier 2005
Statut
Contributeur
Dernière intervention
5 avril 2021
1 402
Bonjour,

Si tu as bien placé la vidéo sur le serveur qui héberge ton site, il faut vérifier le nom et le chemin de la vidéo, c'est à dire, vérifier qu'il n'y a pas une majuscule ou que la vidéo ne se trouve pas dans un dossier.
Messages postés
262
Date d'inscription
mardi 10 novembre 2015
Statut
Membre
Dernière intervention
6 septembre 2020
14
Bonjour,
Je teste en local, j'utilise wamp. La vidéo est bien à la racine du projet.
Peut-être sur le serveur Apache ?
Mais, je ne vois pas comment.
Merci encore
Messages postés
6049
Date d'inscription
mercredi 19 janvier 2005
Statut
Contributeur
Dernière intervention
5 avril 2021
1 402
Je n'utilise pas WAMP, je suis sous Linux, je ne sais plus si le dossier racine est www ou htdocs, mais quoi qu'il en soit, le dossier qui contient ton site doit se trouver dans un de ces deux dossiers, par exemple :

"htdocs/ton_site/index.html"

Dans ton code, le fichier vidéo se trouve au même niveau que index.html :

"htdocs/ton_site/diamant.mp4"

Messages postés
262
Date d'inscription
mardi 10 novembre 2015
Statut
Membre
Dernière intervention
6 septembre 2020
14
Il est exactement comme tu dit. Sous wamp c'est www.
Faut-il avoir Flash Player ? Je l'ai téléchargé, mais je ne le trouve pas.
Sais-tu dans quel dossier il le met ?
Merci beaucoup por ton aide
Messages postés
6049
Date d'inscription
mercredi 19 janvier 2005
Statut
Contributeur
Dernière intervention
5 avril 2021
1 402
Ce code HTML5 n'utilise pas Flash Player.
Messages postés
262
Date d'inscription
mardi 10 novembre 2015
Statut
Membre
Dernière intervention
6 septembre 2020
14 >
Messages postés
6049
Date d'inscription
mercredi 19 janvier 2005
Statut
Contributeur
Dernière intervention
5 avril 2021

Merci pour ton aide.
J'ai trouvé, c'était la vidéo qui ne fonctionnait pas, j'ai essayé avec une autre etça marche bien.
Question résolue