Iptables & Proftpd

[Résolu/Fermé]
Signaler
Messages postés
541
Date d'inscription
lundi 9 janvier 2017
Statut
Membre
Dernière intervention
17 février 2020
-
Messages postés
30119
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 septembre 2021
-
Bonjour,

J'ai un serveur FTP sous Proftpd et j'utilise iptables comme pare-feu.

Le serveur FTP fonctionne parfaitement.
J'ai un script qui s'active au démarrage du serveur et qui bloque toutes les connexions sur le pare-feu, ensuite il accepte seulement quelques connexions : ssh, proftpd ...

Le problème c'est que le proftpd ne fonctionne pas. J'arrive à me connecter mais le dossier FTP n'est pas récupéré, filezilla me dit ça
Statut :
Connexion à 192.168.1.23:21...
Statut : Connexion établie, attente du message d'accueil...
Statut : Serveur non sécurisé, celui-ci ne supporte pas FTP sur TLS.
Statut : Connecté
Statut : Récupération du contenu du dossier..,

Les règles de filtrage dans le script sont :
# FTP Out
iptables -t filter -A OUTPUT -p tcp --dport 21 -j ACCEPT
iptables -t filter -A OUTPUT -p tcp --dport 20 -j ACCEPT

# FTP In
iptables -t filter -A INPUT -p tcp --dport 20 -j ACCEPT
iptables -t filter -A INPUT -p tcp --dport 21 -j ACCEPT
iptables -t filter -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
echo "ftp ok"


Je vois pas trop ou est le problème, si quelqu'un pourrait m'expliquer.
A noter que si je désactive le pare feu, ça fonctionne, le problème vient donc des commandes ici

Merci
After all this time ? Always

2 réponses

Messages postés
30119
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 septembre 2021
7 174
Bonjour,

As-tu essayé ces règles ?
https://unix.stackexchange.com/questions/93554/iptables-to-allow-incoming-ftp

Bonne chance
Messages postés
541
Date d'inscription
lundi 9 janvier 2017
Statut
Membre
Dernière intervention
17 février 2020
181
Le problème de fichier non récupéré est résolu. Il faut charger le module suivant :
modprobe ip_conntrack_ftp


Cependant j'ai un autre problème, pour chiffrer mes connexions FTP j'ai un certificat SSL qui fonctionne correctement. Cependant lorsque j'active le SSL il n'arrive plus à récupérer le dossier mais il y arrive quand je le désactive.

Il y a donc un problème entre le SSL et le pare feu. Quelqu'un a une idée ?

merci
Messages postés
30119
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 septembre 2021
7 174
Merci pour l'explication !

Par rapport à ta question, vu que c'est un nouveau problème, peux-tu le poser dans un nouveau fil de discussion et marquer celui-ci en résolu ?
https://www.commentcamarche.net/faq/11365-marquer-un-fil-de-discussion-comme-etant-resolu

Le but étant de garder un forum lisible, avec un fil de discussion par problème.