Problème sur recopie auto macro

Fermé
Signaler
-
 Franck -
Bonjour,

Bonjour,

je souhaites faire une recopie auto sur une formule comme sur le fichier ci joint,

cependant j'ai une erreur dans mon code que je ne peux résoudre.
http://www.cjoint.com/c/FJgsqKuWfxg

4 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
525
Ton classeur ne prend pas en charge les macros (extension xlsx)
Il n'y a donc aucun code.

Essaie comme cela :
Sub Test()
Dim DerLig As Long
With Worksheets("Feuil1")
DerLig = .Range("A" & Rows.Count).End(xlUp).Row
.Range("B2").AutoFill Destination:=.Range("B2:B" & DerLig), Type:=xlFillDefault
End With
End Sub

A+
1
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
525
Bonjour,

De quel code parles-tu ?

S'agit-il de copier la formule de Feuil1!B2 dans la plage Feuil1!B2:B5 ?
=NB.SI.ENS(Ressources!A:A;A2;Ressources!D:D;"OK";Ressources!E:E;"Franck")

Si c'est le cas, pourquoi ne pas utiliser la poignée de recopie ?


A+
0
Bonjour, vous ne pouvez visualiser le code du fichier Excel joint ?

Les données de la colonne A peuvent varier.
Aussi je cherches le code me permettant de renseigner la colonne B2 jusqu'à derligne mais mes essais ne fonctionne pas et j'aimerais comprendre d'où vient le problème.

La fonction autofill plutôt que de descendre vers derligne remonte sur l'en-tête.
Peut être du fait que les ligne en dessous de B2 sont vide ?
Et qu'il faut donc ne pas sélectionner "B2:B"
Mais plutôt une colonne non vide comme la colonne A ?
0
Bonjour,

Merci cela fonctionne
0