Formule d'arrondi par rapport à une donnée

Fermé
Fifon - Modifié par Fifon le 3/10/2016 à 13:04
Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 - 3 oct. 2016 à 14:49
Bonjour,

Débutant sur excel j'ai un petit soucis et je ne trouve pas ma réponse sur la toile...
Sur un de mes tableurs excel, je souhaiterai que mes résultats s'arrondissent automatiquement à 0 , 2 ou 3 chiffres après la virgules en fonction de s'il s'agit de m², de m³, de kg... etc
à côté du résultat j'ai un menu déroulant avec la liste de toutes les unités que j'utilisent donc l'idée serait que lorsque dans mon menu déroulant je choisis "m²" le résultat d'à côté s'arrondisse à 2 chiffres après la virgule par exemple. J'ai essayé avec une formule de type :

SI(B12="m2";ARRONDI(A12;2);SI(B12="m3";ARRONDI(A12;3)...etc

mais ça ne marche pas...

D'avance merci!

3 réponses

JvDo Messages postés 1978 Date d'inscription mercredi 27 juillet 2005 Statut Membre Dernière intervention 28 septembre 2020 850
Modifié par JvDo le 3/10/2016 à 13:30
Bonjour,

Tu remplaces A12 par la formule contenue dans A12.
Tu peux même mettre (en A12) une formule réduite :
=ARRONDI(ma_formule;--DROITE(B12))

Cordialement

edit : si tu as des m² et des m³ au lieu des m2 et m3, il faut remplacer --DROITE(B12) par MOD(CODE(DROITE(B12));128)-48
0
Merci pour cette réponse JvDo!
Cependant, ce n'est pas encore bien clair pour moi, j'ai essayé sur mon tableau, mais sans trop de résultat... :/ J'ai (essayé) de mettre ta formule en L14 (ma colone de résultat). Dans les autres cellules de cette même colonne il y a la formule d'origine et dans la colone M les menus déroulants avec lesquelles je choisis mon unité.
Je met le lien en fichier ci-joint.
Merci beaucoup
http://www.cjoint.com/c/FJdlPrgzykB
0
Patrice33740 Messages postés 8550 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 28 septembre 2022 1 758
3 oct. 2016 à 14:27
Bonjour,

Sans arrondir le résultat, tu peux utiliser une MFC conditionnelle (à partir d'excel 2010)
Exemple : https://www.cjoint.com/c/FJdmA0AqbNC
0
Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 534
3 oct. 2016 à 14:49
Bonjour,

Pour obtenir l'arrondi :
=ARRONDI(SI(F14="T";AT13;"");CHOISIR(EQUIV(M14;{"ml";"m2";"m3";"kg";"U"};0);1;2;3;2;1))

Par contre, note bien qu'il s'agit d'un arrondi à x décimales et non pas d'un affichage avec x décimales.

Exemple :
la valeur 71,297 arrondie à 2 décimales et affichée au format standard renverra 71,3.
Cette même valeur 71,297 arrondie à 1 décimale et affichée au format standard renverra 71,3.
Cette même valeur 71,297 arrondie à 1 décimale et affichée au format nombre à 2 décimales renverra 71,30.

A+
0