Enlever #VALEUR! [Fermé]

Signaler
Messages postés
66
Date d'inscription
mercredi 30 septembre 2015
Statut
Membre
Dernière intervention
3 février 2019
-
Messages postés
2215
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
17 juillet 2021
-
Bonjour,

Pourriez vous comment enlever le #valeur! dans ma formule suivante :

=SI(ESTNA(RECHERCHEV(F10;'Réf Apporteur D''affaires'!$A$2:$B$4;2;FAUX));"";(RECHERCHEV(F10;'Réf Apporteur D''affaires'!$A$2:$B$4;2;FAUX)))*G10

Merci à tous pour votre aide :-)

Bonne soirée

A voir également:

7 réponses

Messages postés
1723
Date d'inscription
samedi 25 février 2012
Statut
Membre
Dernière intervention
29 mars 2018
355
Messages postés
66
Date d'inscription
mercredi 30 septembre 2015
Statut
Membre
Dernière intervention
3 février 2019

Merci pour le lien mais j'ai essayé de rajouter ESTERREUR mais je n'arrive pas à le mettre au bon endroit :-(
Messages postés
54279
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 juillet 2021
16 250
Comme te le sais parfaitement, joindre son fichier est un avantage certain pour espérer obtenir une réponse valable ...
Messages postés
26102
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
5 988
Bonjour

sans trop savoir ce que fait votre formule, pour Excel à, partir de 2007 seulement

=SIERREUR(RECHERCHEV(F10;'Réf Apporteur D''affaires'!$A$2:$B$4;2;FAUX)*G10);"")
c'est à dire:
=SIERREUR(la formule, complète);"")
vous pouvez rajouter une information texte (genre ""non trouvée") entre les derniers guillemets

ou encore

avant 2007:

=SI(NB.SI('Réf Apporteur D''affaires'!$A$2:$A$4;F10);RECHERCHEV(F10;'Réf Apporteur D''affaires'!$A$2:$B$4;2;FAUX)*G10;"")

en supposant bien sur que pour faire l'opération B2:B4 et G10 ne contiennent que valeurs numériques, car si le résultat est valeur, ,c'est que la multiplication ne peut pas se faire


crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
66
Date d'inscription
mercredi 30 septembre 2015
Statut
Membre
Dernière intervention
3 février 2019

Merci à tous pour votre aide :-)

Mais si.... j'ai des valeurs numériques sur les plages de recherches... en fait je cherche un apporteur d'affaires dans un tableau, prendre le pourcentage lui correspondant dans la colonne 2, puis prendre ce pourcentage et le multiplier par le chiffre d'affaire (G10).

Quelqu'un a t il une idée pour une solution ?

Merci et bonne journée
Messages postés
26102
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
5 988
et que donnent les propositions faites, par exemple cette formule:

=SI(NB.SI('Réf Apporteur D''affaires'!$A$2:$A$4;F10);RECHERCHEV(F10;'Réf Apporteur D''affaires'!$A$2:$B$4;2;FAUX)*G10;"")
Messages postés
66
Date d'inscription
mercredi 30 septembre 2015
Statut
Membre
Dernière intervention
3 février 2019

Merci Vaucluse, mais cela ne me donne rien :-(
Messages postés
17408
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
21 juillet 2021
4 667
Bonjour,

peut être as tu une formule en amont qui renvoi déjà le message d'erreur #VALEUR
il faudrait avoir sous les yeux un bout de ton fichier anonymisé pour apporter une réponse adaptée pour cela suit ce lien et donne au passage ta version d'Excel
1) Clic sur ce lien https://www.cjoint.com/
2) Clic sur le bouton Parcourir pour sélectionner ton fichier
3) Clic sur le bouton Créer le lien en bas de la page
4) Au bout de quelques secondes en haut de la page en bleu souligné un lien sera généré, tu le sélectionnes et tu le copies dans une réponse
Messages postés
66
Date d'inscription
mercredi 30 septembre 2015
Statut
Membre
Dernière intervention
3 février 2019

Merci Mike-31, je vais alléger mon fichier est l'envoyer... mais pour l'instant j'ai trop d'infos "touchy" dedans :-)
Messages postés
4148
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1 414
Bonjour
Pourquoi un double '' avant affaires?
'Réf Apporteur D''affaires'
Crdlt
Messages postés
2215
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
17 juillet 2021
324
Bonjour jc80
Excel encadre les noms de feuilles avec une apostrophe, or la présence de l'apostrophe derrière le D de D'Affaires est perçu par excel comme une fin ou un début du nom de la feuille, et comme elle se trouve au milieu du nom complet, il complète ce qu'il manque, donc 'Ref Apporteur D' et 'Affaires' ce qui fait bien
'Ref Apporteur D' 'Affaires'
Voilà
Cdlt