Mise en forme conditionnelle Excel

Fermé
Elisabeth - 8 août 2007 à 17:58
hmcirta Messages postés 215 Date d'inscription dimanche 12 mars 2006 Statut Membre Dernière intervention 8 novembre 2022 - 13 août 2007 à 23:44
Bonjour,
Mon souci concerne la mise en forme conditionnelle avec Excel.

Dans une colonne A, j´aimerais inscrire les montants provisoires d´une facture
et les montants réels d´autres factures.
ce qui différencie ces 2 types de montants est la couleur.
ex. : rouge pr les montants provisoires et noir pr les montant réels.
En cellule A1 : la somme de la colonne entière : facile à faire mais :
serait-il possible de faire une somme en A1 pour les montants en noirs et en A2 les montants en rouge mais tout cela bien sur automatiquement.
Si le montant que je saisis est en rouge, il ira automatiquement s´ajouter au montant dans A2.
Avez-vous une solution à me proposer ?
Merci!
Lisa

4 réponses

hmcirta Messages postés 215 Date d'inscription dimanche 12 mars 2006 Statut Membre Dernière intervention 8 novembre 2022 23
13 août 2007 à 17:23
Salut

Pour le calcul automatique des montants Provisoires et Réels, tu peux utiliser la fonction "somme.si".
Tu peux ajouter une colonne avec par exemple P pour provisoires et R pour réels en face de chaque montant de ta colonne A, puis saisir la formule suivante dans la cellule A1 : =SOMME.SI(B2:B27;B1;A2:A27)
Avec :
B2:B27 = plage de cellules contenant P ou R
B1 = une cellule où tu mettras P ou R selon que tu veux la somme de montants Provisoires ou Réels
A2:A27 = La plage de cellules de la colonne A

Reste plus à modifier la cellule B1 en saisissant P ou R

Ceci c'est pour la somme automatique.

A+
0
hmcirta Messages postés 215 Date d'inscription dimanche 12 mars 2006 Statut Membre Dernière intervention 8 novembre 2022 23
13 août 2007 à 18:07
Pour la mise en forme conditionnelle

Tu sélectionnes la colonne A des montants puis tu vas à "Format  Mise en forme conditionnelle", là tu modifies "La valeur de la cellule est" par "La formule est" puis tu click à droite ensuite tu sélectionnes la première cellule de la colonne B qui contient P ou R, tu devrais avoir ceci : =$B$2, tu saisies ce qui suit : ="P" (P entre guillemets). En suite tu supprimes le signe dollar avant le 2 pour avoir à la fin ceci : =$B2="P", de cette façon tu appliqueras la mise en forme conditionnelle à toutes les cellules de A d'un coup.

Il ne rest plus qu'à choisir la mise en forme que tu veux

Fais moi signe si ça marche

A +
0
Selecteur Messages postés 44 Date d'inscription samedi 12 février 2005 Statut Membre Dernière intervention 29 septembre 2013 6
13 août 2007 à 18:44
Bonjour,

Pour l’affectation des couleurs :

Sélectionne la plage de A2 à A7 puis menu Format Mise en forme conditionnelle choisir dans le premier champ la valeur de la cellule est puis dans le second champ choisir différente de puis dans le troisième champ «» (deux guillemets de suite sans rien à l’intérieur) puis bouton Format et sélectionne ta couleur puis valide deux fois par ok.

Fais la même chose pour l’autre plage et donc l’autre couleur.

Pour faire la somme en A1 tu peux mettre : =SOMME.SI(A2:A7;"<>""")

Fais attention aux guillemets, il y en 4 !

Formule à adapter pour la somme des montants réels.

Bon courage

Selecteur.
0
hmcirta Messages postés 215 Date d'inscription dimanche 12 mars 2006 Statut Membre Dernière intervention 8 novembre 2022 23
13 août 2007 à 23:44
Salut

Voici une une petite capture vidéo sur la procédure à faire. J'espere qu'elle pourra vous aider

http://www.badongo.com/vid/447803

A+
0