Openvpn site to site.

Fermé
xxx31fr Messages postés 87 Date d'inscription samedi 25 décembre 2004 Statut Membre Dernière intervention 6 septembre 2016 - 5 avril 2016 à 11:59
 Chris - 6 avril 2016 à 22:34
Bonjour,

J'ai un problème pour setup un VPN (OpenVPN site to site).

1. le client OpenVPN ping le serveur VPN et les VMs qu'il y a sur le lan du serveur
2. un PC du Lan du client OpenVPN ping le serveur OpenVPN et les VMs du Lan où se trouve le serveur OpenVPN
3. le serveur OpenVPN ping le client OpenVPN
4. un PC du Lan du serveur OpenVPN ping le client OpenVPN et les PCs du Lan où se trouve le client OpenVPN

Là où cela bloque:
5. Un PC se trouvant dans le Lan du client OpenVPN ne peut se connecter à une VM se trouvant sur le Lan du serveur OpenVPN
Exemple: connexion SSH (port 22) ou connexion RDP (3389)
6. Un PC se trouvant dans le Lan du client OpenVPN initie une connexion direct au serveur OpenVPN, il arrive à effectuer une connexion SSH (port 22) ou connexion RDP (3389) sur une VM du lan du serveur
7. Un PC se trouvant dans le Lan du serveur OpenVPN ne peut se connecter à un PC se trouvant sur le Lan du client OpenVPN
Exemple: connexion SSH (port 22) ou connexion RDP (3389)


Je copie/colle les fichiers de conf que j'ai:

Voici la conf serveur:
#serveur TCP/443
#mode server
proto tcp
port 1194
dev tun

# Cles et certificats
ca ca.crt
cert server.crt
key server.key
dh dh1024.pem
cipher AES-256-CBC

# Reseau
server 10.8.0.0 255.255.255.0
push "route 10.10.1.0 255.255.255.0"
push "route 192.168.0.0 255.255.255.0"
push "route 10.10.10.0 255.255.255.0"
client-config-dir ccd
#route 10.9.0.0 255.255.255.252
route 192.168.0.0 255.255.255.0
route 10.10.10.0 255.255.255.0
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 10.10.1.254"
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
push "dhcp-option DOMAIN itcast.local"
push "dhcp-option SEARCH itcast.local"

# Options
persist-key
persist-tun
# Keepalive: send ping every 10 seconds, tunnel down after 120 seconds no response.
keepalive 5 60
reneg-sec 432000

# Securite
user nobody
group nogroup
comp-lzo

client-to-client
username-as-common-name
client-cert-not-required
auth-user-pass-verify /etc/openvpn/script/login.sh via-env
;plugin /usr/lib/openvpn/openvpn-auth-pam.so common-auth
;duplicate-cn

# script connect-disconnect
script-security 3 system
client-connect script/connect.sh
client-disconnect script/disconnect.sh

# Log
verb 3
mute 20
status /var/log/openvpn/server_tcp.log
log-append /var/log/openvpn/openvpn.log
up /etc/openvpn/update-resolv-conf
#down /etc/openvpn/update-resolv-conf

Fichiers dans dossier ccd:
client1
ifconfig-push 10.9.0.1 10.9.0.2
iroute 192.168.0.0 255.255.255.0

client2
ifconfig-push 10.9.1.1 10.9.1.2
iroute 10.10.10.0 255.255.255.0

Configuration client:
# Client
client
dev tun
proto tcp
remote <IP DU SERVEUR OPENVPN> 443
resolv-retry infinite
cipher AES-256-CBC


# Cles
auth-user-pass
reneg-sec 432000

# Securite
nobind
persist-key
persist-tun
comp-lzo
verb 3
redirect-gateway
route-metric 9999

<ca>
CONTENU CERTIFICAT CA
</ca>

En vous remerciant par avance pour votre aide.

A voir également:

3 réponses

xxx31fr Messages postés 87 Date d'inscription samedi 25 décembre 2004 Statut Membre Dernière intervention 6 septembre 2016
5 avril 2016 à 12:47
je remodifie mes tests.
Après modifications des fichiers de conf serveur OpenVPN:

1. depuis une VM du lan du serveur OpenVPN, je n'ai plus le ping vers les PCs du la du client OpenVPN.

2. Par contre, depuis le serveur OpenVPN, le ping vers le client et les PCs du lan du client sont fonctionnels...

Si vous pouvez m'aider ......merciiiiiiiii
0
xxx31fr Messages postés 87 Date d'inscription samedi 25 décembre 2004 Statut Membre Dernière intervention 6 septembre 2016
5 avril 2016 à 17:39
Personne pour me donner un petit coup de main??
0
Ta vérifié tes règles de FW ?
Route, Filtrage ..?
0