Formule MAX avec 4 conditions

[Fermé]
Signaler
-
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
-
Bonjour,

J'ai Excel 2010, je travaille sur un tableau et je souhaiterai faire une formule MAX qui me permette de retrouver le MAX d'une colonne selon 4 conditions.


Je m'explique
J'ai plusieurs onglet et un tableau recap, sur ce tableau recap je veux y mettre le max par jour et de 3h du mat jour J à 3h du mat le lendemain.

Par exemple, je veux que pour le 02/01 à 3h15 jusqu'au 03/01 à 03h qu'il me donne le max de la colonne E

Colonne 1 : Date
Colonne 2 : heure
Colonne 3 : les données chiffrées

Merci par avance de votre aide!

1 réponse

Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
28
Bjr,

Si je comprends bien, il faut afficher en face de chaque ligne le maximum sur le créneau 3h15-3h00, sachant que pour chaque ligne si l'heure est inférieure à 3h15, il faudra comparer depuis le jour d'avant et si elle supérieure à 3h15 il faudra comparer jusqu'au jour d'après.

Cette formule marche de mon côté pour ce que je viens de décrire :
(valider en matriciel Shift+Ctrl+Entrée)
=SI(B1>"03:15:00"*1;MAX(SI((A:A>=A1)*(A:A<=DATE(ANNEE(A1);MOIS(A1);JOUR(A1)+1));C:C));MAX(SI((A:A<=A1)*(A:A>=DATE(ANNEE(A1);MOIS(A1);JOUR(A1)-1));C:C)))


Cdt,
BOnjour Theo R

La formule ne fonctionne pas.
Je me suis surement mal exprimée.

J'ai un onglet de données qui est comme suit :

Date Heure Données
01/01/2016 03:15:00 10
01/01/2016 03:30:00 25
01/01/2016 03:45:00 8
.......
02/01/2016 02:45:00 38
02/01/2016 03:00:00 32

La journée va du 01/01/2016 à 3h15 pour se terminer le 02/01/16 à 03h00.
J'aimerai trouver la valeur max.
Ici la valeur max est 38

J'espere que c'est plus clair.

Merci par avance de votre aide!

Cdt
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
28
Re,

Alors 2 choses :

1) Pour que ma formule marche, votre colonne avec les dates doit bien avoir un format date (sinon sélectionnez la colonne, allez dans Données -> Convertir -> Suivant -> Suivant -> Date (JMA) -> Terminer)

2) La borne 3:15 n'était pas précise (ouverte ou fermée), du coup je comprends maintenant que si l'heure vaut 3:15 pile, alors on passe à la journée d'après.

Essayez donc cette formule en matriciel toujours après avoir vérifier ma remarque 1) :
=SI(B1>="03:15:00"*1;MAX(SI((A:A>=A1)*(A:A<=DATE(ANNEE(A1);MOIS(A1);JOUR(A1)+1));C:C));MAX(SI((A:A<=A1)*(A:A>=DATE(ANNEE(A1);MOIS(A1);JOUR(A1)-1));C:C)))