Accès serveur FTP [Résolu/Fermé]

Signaler
-
Messages postés
92852
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
3 août 2020
-
Bonjour,

J'ai créé un serveur ftp sur mon PC qui est situé derrière un modem routeur CBox. J'ai réalisé cela avec TypSoft et ai bien ouvert les ports correspondants dans mon modem.

ftp://visiteur:12345@homelenoir.no-ip.info

Les accès à mon serveur se font apparemment bien, par l'intermédiaire d'un PC distant avec Internet explorer que je vois se connecter dans le journal de Typsoft. Le problème est que la personne connectée ne vois pas mes fichiers et qu'elle obtient un message lui indiquant qu'elle n'a pas accès.

Je ne comprend pas comment d'un côté, le client n'a pas accès alors que de mon côté, je vois bien qu'il est connecté! Y'a un truc, mais lequel !?!

Merci de bien vouloir me filer des infos à ce sujet, afin que mon serveur ftp puisse servir à quelque chose...

Naxoyo

3 réponses

Messages postés
12
Date d'inscription
mardi 31 octobre 2006
Statut
Membre
Dernière intervention
30 juillet 2007
2
a mon avis tu bloques sur le PASV
un serveur ftp utilise en realité plusieurs port

-pour la connexion (21 par defaut)
-pour les transferts de données comme le LIST (20 par defaut je crois)

il est donc tout a fait possible que tu vois ton ami connecté a ton serveur sans pour autant qu'il puisse lister le repertoire
donc je te recommande de forward ce port aussi et normalement t'auras plus de souci
Ok, merci pour ta réponse.

En fait, j'ai fais toutes les manip. sur le port 21 et sur le port 20 a chaque fois: Ouverture de ports et du firewall. Donc je pense que pour le 20, ya pas de prob.

Je pense aussi à un truc dans ce genre là, mais peux être avec les ports utilisés en data. De mon côté, c'est bon je pense, j'ai configuré un plage de 54000 à 54200. mais peut-être pas du côté client avec Internet explorer...

Si vous avez d'autres idées, je suis preneur. :-)
Messages postés
92852
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
3 août 2020
10 114
salut
tu as dû configurer une mauvaise adresse ip dans l'adresse affectée au mode passif .
je me connecte bien en ligne de commande .
mais attention : tu n'as pas le droit de partager le fichier que tu proposes (à moins que le titre ne corresponde pas à la chanson) .
Je pense que l'adresse IP affectée au mode passif doit être bonne. C'est mon adresse homelenoir.no-ip.com, ou alors je me trompe?? Est-ce que je dois mettre autre chose?

Quand tu parles de droit, c'est de droit légal, je suppose, pas de droit d'accès réseau?
De ce côté là, ce n'est pas le but, évidemment, j'ai juste mis un titre que j'ai sur mon disque pour faire un test.

Merci pour l'info.
Messages postés
92852
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
3 août 2020
10 114
à vérifier dans typsoft,
mais je crois bien que si on précise une adresse dans la configuration du mode passif, il faut une adresse ip numérique , pas un fqdn , donc ça ne doit pas aller avec no-ip .
je pense que ça devrait aller mieux si tu ne renseignes rien du tout .
le client prendra l'adresse host par défaut .