Iphoto inopérant

Résolu/Fermé
profiler31 Messages postés 436 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 29 septembre 2022 - 24 janv. 2016 à 10:46
 Utilisateur anonyme - 27 janv. 2016 à 14:47
Bonjour,
Je suis sous Mountain Lion 10.8.5 et Iphoto 9.4.3 mise à jour ;
Je veux ouvrir Iphoto et j’ai un message ……nécessite une mise à jour.
J’ai fait un Zip de Iphoto dans les applications.
J’ai mis à la corbeille Iphoto et vidé la corbeille.
J’ai téléchargé la mise à jour de Iphoto dans Appstore (V 9.4.3)
et relancé mon Imac
Quand je clique sur Iphoto, même message « ….nécessite une mise à jour »

Je crois que le sujet à été évoqué mais pas trouvé de solution.

Qq’un peut il me mettre sur la voie ?

Merci d'avance


A voir également:

12 réponses

Bonjour,

Perso, je possède la version iPhoto 9.6.1

Et si ma mémoire est à peu près fonctionnelle, je suis passé à cette version lorsque je suis passé à Mavericks, (OS X 10.9), et il se peut aussi que cette version soit également celle distribuée sous OS X Yosemite (OS X 10.10)

Le problème est qu'aujourd'hui, ces 2 OS ne sont plus fournis, mais remplacés par El Capitan. Or sous El Capitan, c'est Photos qui est fourni à la place d'iPhoto. En clair, sous OS X 10.8, la limite est la version 9.4.3, et sous El Capitan, c'est Photos à la place d'iPhoto.

Le problème que tu rencontres est possible si la photothèque avait été ouverte sur un autre Mac, possédant une version iPhoto plus récente que la tienne, et que cette photothèque a été "mise à jour" pour iPhoto 9.6...

Lorsque on passe à El Capitan, la version iPhoto présente sur son disque reste en place, pas de soucis de ce coté, mais je ne sais si sa mise à jour proposée.

Ce qu'il faudrait que tu tentes, c'est installer El Capitan sur une disque externe, si tu ne le souhaites pas sur ton disque habituelle, puis que tu démarres depuis ce disque externe. Ensuite, tu éjectes ton disque interne de sorte que ta version iPhoto actuelle ne soit pas visible pour qu'App Store te propose le téléchargement.

Après ça, tu vas dans ta session App Store, sur la liste de tes achats, et tu demandes à télécharger iPhoto depuis cette liste. Tu devrais alors te voir proposer la dernière version. Ça pourrait marcher.

Ensuite tu redémarres depuis ton disque normal, tu renommes cette version en iPhoto96, par exemple, pour permettre son collage sur le disque interne, et tu testes si l'ouverture d'iPhoto nouvelle version fonctionne sous OS X 10.8.5 - mais attention, ne teste pas dans un premier temps sur ta bibliothèque habituelle, pour éviter de l'upgrader si cette version d'iPhoto fonctionne mal. Lance iPhoto avec la touche ait enfoncée pour te permettre de créer une nouvelle bibliothèque.

J'espère avoir été clair :)

EDIT : on voit ici, que j'ai obtenu la version 9.6 le 24 octobre 2013, donc 2 jours après la sortie de OS X 10.9 dite Mavericks :



Bonne Journée :-) - Francis
Indiquez toujours votre configuration système exacte et lisez intégralement la réponse donnée
0
profiler31 Messages postés 436 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 29 septembre 2022 38
24 janv. 2016 à 18:50
Bonsoir Francis,
J’ai galéré tte la journée sur le sujet. J’ai un Macbook avec El Capitan qui possède Iphoto (V 9.4.3) et Photo.
J’ai donc sauvegardé le ficher Images de mon Imac sur mon MacBook.
J’ai viré Iphoto de mon Imac et vidé la corbeille.
J’ai fait un copier de l’application Iphoto qui fonctionne sur mon Book que j’ai collé sur Imac (V 9.4.3) et j’ai obtenu ce message :"… vous avez OSX 10.8.5 L’application requiert OSX 10.10 ou ultérieur »
Cette démarche est proche de celle que tu m’as indiquée mais ne fonctionne pas.
J’ai tenté une MAJ sur APPStore, mais la version proposée est l’ancienne 2012 et non 2013 comme tu l’indiques.
Alors je n’ai pas d’autre solution que de conserver Iphoto sur mon Book ou de passer à El Capitan sur Imac.
Dans ce dernier cas, un passage de Mountain Lion à El Capitan se fait- il dans la douleur ???

Merci de ton conseil
0
Utilisateur anonyme
24 janv. 2016 à 20:30
Très bizarre ce truc...

le passage à El Capitan, pour ce qui me concerne s'est parfaitement déroulé. le système est fluide, mieux que sous Yosemite, mais sauf que la dernière mise à jour, c'est à dire la 10.11.3 m'a causé des soucis de lenteurs avec Safari et Firefox... j"ai fouillé, testé.. pas trouvé d'ou viens le souci. J'ai alors installé El Capitan à neuf sur un disque externe, et là je l'ai mis à jour en 10.11.2, c'était parfait. Et donc, je viens d'effacer mon disque dur interne pour refaire une installation neuve et me limiter à 10.11.2

Donc tout va bien, mais pour moi la mise à jour 10.11.3 me crée des soucis.
0
profiler31 Messages postés 436 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 29 septembre 2022 38
24 janv. 2016 à 22:47
Donc si je charge el capitan je dois me limiter à la v 10.11.2 !

Mais ma question est la suivante : est il possible de passer de Mountain Lion à El capitan sans passer par les versions intermédiaires ?
et si oui la mise à jour proposée par Apple dans appstore est elle fiable ?

Merci
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Utilisateur anonyme
24 janv. 2016 à 23:29
Inutile de passer par des versions d'OS intermédiaires. On peut aller directement à El Capitan depuis Mac OS X 10.6.

Pour ce qui est de la version 10.11.3, je dirai oui, mieux vaut se limiter à 10.11.2 selon mon expérience personnelle. Ou alors, il y a un truc anormal chez moi.
En tous cas, j'ai placé la mise à jour combinée 10.11.3 dans mon dossier Applications, comme ça, si une mise à jour y est proposée, je serai averti.

Pour ma part j'ai installé El Capitan depuis une version 10.11.0 que j'avais en réserve et j'ai ensuite téléchargé la version mise à jour combinée 10.11.2

Mais Je ne sais pas si la version fournie actuellement depuis App Store est en 10.11.0, ou 10.11.1 ou .2 ou .3 ??
0
profiler31 Messages postés 436 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 29 septembre 2022 38
24 janv. 2016 à 23:47
Merci,
Curieusement quand j’ai copié/collé Iphoto version 9.6.1 de 1,7 Go dans les applications de mon Imac, dans" lire les informations" de Iphoto, je trouve version 9.4.3 de 1,7 Go (alors que cette version ne fait que 1,2 Go).
Puis si je veux faire une mise à jour depuis appstore il ne me propose que la version 2012 (c’est a dire celle pour OSX 10.8.5 !
C’est assez incompréhensible.

Enfin la version El Capitan de appstore est maintenant en 10.11.3.
En tout cas merci . Si tu as une idée de génie pour Iphoto tu m’appelles ?

Bonsoir et à +
0
Utilisateur anonyme
25 janv. 2016 à 00:00
Tu as trouvé la version 9.6.1 ?
0
profiler31 Messages postés 436 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 29 septembre 2022 38
25 janv. 2016 à 09:25
Bonjour,
Oui, la 9.6.1 qui équipe mon macbook sous el capitan.
0
Utilisateur anonyme
25 janv. 2016 à 10:59
Bonjour,

Alors ton souci provient très probablement du fait que ta bibliothèque iPhoto avait déjà été ouverte sous iPhoto 9.6, et de ce fait, elle a été "mise à niveau" pour la version 9.6.

Tu as peut-être, (probablement ?), transférer la photothèque d'un Mac à l'autre ?

Il est alors normalement impossible d'ouvrir cette photothèque avec une version plus ancienne que 9.6. Je dis normalement, car il y a des techniques que l'on trouve ici ou là.
Mais je crois me souvenir qu'il y avait également une méthode pour ouvrir à nouveau cette photothèque avec la dernière version et la sauvegarder ou exporter vers une version plus ancienne. Je n'ai pas la procédure sous la main, mais peut-être qu'en faisant des recherches je retrouverai...

Une piste donc à envisager...
0
profiler31 Messages postés 436 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 29 septembre 2022 38
25 janv. 2016 à 13:19
Re
Oui c’est probablement ça ! car quand j’ai eu mon macbook El Capitan j’y ai transféré mes fichiers et applications.

Donc si tu as une piste (et quelques disponibilités pour retrouver la procédure) pour remettre en l’état elle sera bienvenue.

Pour l’instant je charge El Capitan en réserve avant de lancer la migration.
Je travaille avec Iphoto sur mon macbook.

Bonne journée
0
Utilisateur anonyme
25 janv. 2016 à 14:20
J'ai retrouvé l'utilitaire qui semble-t-il permet l'ouverture d'une photothèque récente avec une ancienne version iPhoto c'est " iPhoto Library Manager "

https://www.fatcatsoftware.com/iplm/

https://www.fatcatsoftware.com/iplm/Help/downgrading%20a%20library%20to%20an%20earlier%20version%20of%20iphoto.html

En espérant que la version démo fasse le boulot..
0
profiler31 Messages postés 436 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 29 septembre 2022 38
25 janv. 2016 à 16:47
Merci,
J’ai chargé, lancé et bidouillé ce logiciel (démo) et suis parvenu à ouvrir la version iPhoto 9.4.3 qui est compatible avec ML 10.8.5.

Ça semble stable ! J’ai importé tous mes évènements d’une sauvegarde iPhoto vers cette version ; tout est bien rentré et dans le bon ordre.
Un grand merci et ce logiciel est à recommander.
Du coup je ne migre pas vers El Capitan (je conserve en réserve).
Merci encore et à une autre fois.
Bonne soirée
0
Utilisateur anonyme
25 janv. 2016 à 17:16
Parfait alors :)
0
Utilisateur anonyme
26 janv. 2016 à 18:28
Bonjour,

Petit retour d'info ;

je reviens sur le point de la mise à jour El Capitan en 10.11.3
Comme je te le disais, ça me provoquait des ralentissements incroyables dans Safari, Firefox etc... j'ai également indiqué que j'avais "tout" testé sans trouver la cause.

J'avais "tout" testé, y compris désactiver mon coupe-feu Little Snitch, et désactiver mon anti-virus ESET Cybersecurity. Sans résultat. Sauf que...

Sur un disque externe, j'ai installé OS X El Capitan, et me suis dans un premier temps arrêté à OS X 10.11.2 - tout était parfait. Puis je suis passé à 10.11.3 - rien d'anormal tout va bien, même si Safari semble très légèrement plus lent. Mais Firefox est nickel. (très bien la dernière version de Firefox).

Sur ce disque externe je n'avais pas installé mon coupe-feu Litlle Snitch, ni mon anti-virus ESET.

Donc, j'installe l'anti-virus ESET - et là c'est à nouveau la catastrophe.
Je désactive ESET - pareil. Alors, je supprime complètement ESET en supprimant toutes les traces de cette application et redémarre depuis ce disque externe, et bingo. Ça marche parfaitement.

C'est donc ESET + 10.11.3 qui ne s'entendent pas. Je ne saurai dire si le problème est essentiellement sur OS X ou sur ESET. Ce qui est certain, c'est que ça va se savoir aussi bien chez Apple que chez ESET.

Comme mon abonnement chez ESET se termine prochainement, je ne l'ai pas ré-installé. Je suis passé à BitDefender qui me semble moins ralentir le système, même avec ses outils anti-adwares supplémentaires installés dans Safari et Firefox.

Mais, pour le moment, je reste malgré tout sous OS X 10.11.2, car si un anti-virus donné cause problème avec la version 10.11.3, cela peut être le cas aussi pour tous les anti-virus, si ce problème est du au renforcement de la protection interne "Xprotect" propre à OS X.

En clair, OS X 10.11.3 fonctionne parfaitement, mais n'aime pas ESET Cybersecurity, et n'aime peut-être pas non plus les autres antivirus.

@++
0
profiler31 Messages postés 436 Date d'inscription samedi 25 septembre 2010 Statut Membre Dernière intervention 29 septembre 2022 38
26 janv. 2016 à 23:02
Bonsoir Francis,

Que voila une bonne nouvelle pour faire évoluer El Capitan ! Les développeurs de chez Apple vont être contents !
Je n’ai donc plus aucune raison valable pour différer ma migrations vers 10.11.3 ; ce que je vais faire car je n’ai pas installé d’antivirus sur mes Mac’s ; juste sur le portable Windows 7.
Pour info Iphoto fonctionne maintenant parfaitement sous ML

Bonne soirée
Cordialement
0
Salut,

Suite de mes investigations :-)

Après quelques problèmes rencontrés sur Safari, même en version OS X 10.11.2, (J'avais constaté des blocages de cette barre d'adresse, et des affichages superposés dans cette barre), j'ai poussé plus loin les recherches, et constaté que ce problème dans la barre d'adresse dans Safari se résolvait en décochant la case "Inclure les suggestions du moteur de recherche" dans les Préférences de Safari. Cela avec ou sans antivirus.

Pour aller plus loin, j'ai redémarré mon Mac depuis mon disque externe sous OS X 10.11.3
Et là j'ai décoché ce choix dans Safari et aussi dans FireFox,
puis j'ai installé mon anti-virus sur ce disque externe.
Et là, tout semble fonctionner maintenant correctement avec 10.11.3 et l'antivirus activé.

Il semble donc qu'un bug se produit avec la combinaison des paramètres suivants :

- être sous OS X 10.11
- avoir la case "Inclure les suggestions du moteur de recherche" cochée

- et que ce bug soit considérablement aggravé par l'installation d'un anti-virus si cette case est cochée

- Et que finalement, ce bug disparaisse complètement si on décoche la case "Inclure les suggestions du moteur de recherche" et son équivalence dans Firefox...

Voilà ou j'en suis dans mes investigations :)

EDIT : je viens de passer à 10.11.3 sur le disque interne de démarrage du Mac, + installation de l'anti-virus. Plus de problème, ça roule pour le moment.
0