2 serveurs web accessible extérieur avec IIS

Résolu/Fermé
Signaler
Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018
-
Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018
-
Bonjour, je cherche à héberger 2 sites web sur un PC tournant sous Windows Server 2008 Entreprise que j'ai chez moi.

Pour mettre au clair ce que j'ai fait, j'utilise No-IP ou j'ai créé 2 DNS (hostname) : site1.servehttp.com et site2.servehttp.com

Je souhaite que : le premier site utilise le port 42 et le second site utilise le port 80.

J'ai installé le logiciel NO-IP DUC sur ce PC et j'ai coché les 2 cases des 2 DNS que j’ai créé.
Dans l'interface de la LiveBox :
- j'ai fixé l'IP de ce PC sur 192.168.1.3 ;
- j’ai ouvert les 2 ports en TCP (80 et 42) vers ce PC ;
- j'ai renseigné les 2 DNS (site1.servehttp.com et site2.servehttp.com) dans l'onglet "DynDNS" ;

Sur le PC, dans les paramètres du Pare Feu Windows, j'ai autorisé les 2 ports en TCP.

Dans le Gestionnaire des Services Internet (IIS) :
J'ai beau créé les 2 sites web en mettant :
- dans la case "Adresse IP", l'adresse IP local de ce PC (192.168.1.3) ;
- dans la case "Port" le numéro du port que j'ai choisi pour le site (42 ou 80) ;
- dans la case "Nom d’hôte", le DNS crée par No-IP (site1.servehttp.com ou site2.servehttp.com) ;

Pour les 2, j'ai bien mis le protocole "http", j'ai fixé le "Chemin d’accès" vers le répertoire contant les pages en .html et mis le "Pool d'application sur "DefaultAppPool".

En test directement sur le serveur avec l'adresse localhost :
J’arrive sur la page "Not Found, HTTP 404. The requested resource is not found".

Sur mon pc personnel, en mettant "192.168.1.3 : port", j'obtiens :
- pour le premier site => "Page Web inaccessible, ERR_UNSAFE_PORT"
- pour le second site => "Not Found, HTTP Error 404. The requested resource is not found."

Et en utilisant mon smartphone en 4G, en utilisant le DNS de No-IP, j’obtiens :
- pour le premier site : "Not Found, HTTP Error 404. The requested resource is not found."
- pour le second site : l'affichage de mon site web 2

Voilà, j'espère que tous ces informations vont pouvoir vous aider à résoudre mon problème.

4 réponses

Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018
155
Maintenant, faut que je mette en place mes serveurs FTP pour pouvoir tenir à jour ces 2 sites depuis n'importe ou
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018
155
J'ai finalement réussi à rendre mon serveur FTP accessible depuis l'extérieur avec FileZilla Server.

Il faut aller dans les paramètres, cocher la case « use custom port range : » et on renseigne les ports 60000 et 600001 et il faut ouvrir les ports en TCP dans la box.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
3035
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
29 novembre 2021
427
Bonsoir,

Il y a plusieurs choses dans "ton problème" :

- Il n'est pas nécessaire de faire écouter le second site sur un autre port.
Surtout que tu utilises un port standardisé (TCP42) et il ne correspond pas à de l'HTTP. Au mieux le 8080. (au dessus de 1024 c'est préférable.)

- Le problème du NAT Hairpinning : tu utilises un FQDN internet avec un NAT depuis le même réseau local. Certaines Box ne savent pas bien le gérer.
En gros tu accèdes à une ressource locale avec l'IP internet de la box.
Il faudra gérer ce point à part; il faudra faire les tests avec ton téléphone en 4G.

- Petit souci avec les virtual Hosts sous IIS + IP d'écoute : lorsque tu tentes d'accéder avec http://localhost pour joindre ton site; vu que tu as utilisé les noms d’hôtes virtuels pour les sites, IIS ne sait pas à qui rediriger ta requête HTTP (même si en l’occurrence il n'y a qu'un seul site sur le port d'écoute en question)
L'URL que tu tapes doit correspondre aux noms de site que tu paramètres dans le site sur IIS. Si localhost n'y figure pas ... ba il ne pourra pas rediriger vers le site.

-

Je te préconise :

1. Paramètre qu'un seul site pour le moment. Laisse tomber/supprime le second site pour l'instant.

2. FQDN DynDNS : rien à faire c'est correct.

3. Livebox : enlève la redirection pour le port tcp 42.

4. IIS : Fais tourner le site1 sur le port tcp 80.
5. IIS : mets toutes les IPs en écoute et paramètre lui le nom site1.servehttp.com
Voies si tu peux aussi lui ajouter localhost et son IP locale, si tu veux faire les tests.

6. Test : depuis le téléphone 4G d'accéder à ton URL externe pour le site1 sans donner de numéro de port; le port 80 sera celui utilisé par défaut.
-> ça devrait être OK.

7. Test : en local, modifie ton fichier hosts, et indique lui que site1.servehttp.com pointe sur l'IP 192.168.1.3
Depuis ta machine lorsque tu fais un ping site1.servehttp.com ; ton serveur doit répondre.
Essaie d'accéder depuis ton serveur à l'URL http://site1.servehttp.com
Tu devrais voir le site.

-

8. Second site :
Créé ton second site, faius le écouter sur le même port et même IP que le site1.
9. Paramètre son nom à site2.servehttp.com
10. Fichier hosts : site2.servehttp.com 192.168.1.3
11. Test depuis l'extérieur avec le téléphone 4G l'accès au site2.
12. Test depuis le serveur l'accès au site2




Using a registry "compactor" on top of a registry "cleaner" would be equivalent to rinsing your throat with a swig of Jack Daniels after swallowing a pint of snake oil....
Messages postés
3035
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
29 novembre 2021
427
A noter que le port 20 n'est pas nécessaire non plus, vu que la la connexion se fait en passif (c'est préférable et par défaut).
Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018
155
Je n'arrive pas à exécuter les commandes: voilà une capture d'écran des erreurs:
http://img11.hostingpics.net/pics/780926commande.jpg

Et en respectant le reste, je n'arrive pas à me log au serveur ftp que ce soit avec "ftp://192.168.1.3" sur le serveur ou sur mon pc
Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018
155
J'arrive vraiment pas, il y a l'autre à respecter ?
Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018
155
J'obtient les erreurs suivantes en exécutant les commandes:

C:\Users\Administrateur>ICACLS "%SystemDrive%\Windows\System32\inetsrv\config" /Grant "Network Service":R /T
Network Service: Le mappage entre les noms de compte et les ID de sécurité n'a pas été effectué.
0 fichiers correctement traités ; échec du traitement de 1 fichiers

C:\Users\Administrateur>ICACLS "%SystemDrive%\Windows\System32\inetsrv\config\administration.config" /Grant "Network Ser
vice":R
Network Service: Le mappage entre les noms de compte et les ID de sécurité n'a pas été effectué.
0 fichiers correctement traités ; échec du traitement de 1 fichiers

C:\Users\Administrateur>ICACLS "%SystemDrive%\Windows\System32\inetsrv\config\redirection.config" /Grant "Network Servic
e":R
Network Service: Le mappage entre les noms de compte et les ID de sécurité n'a pas été effectué.
0 fichiers correctement traités ; échec du traitement de 1 fichiers

C:\Users\Administrateur>ICACLS "%SystemDrive%\inetpub\ftproot" /Grant "Network Service":M /T
Network Service: Le mappage entre les noms de compte et les ID de sécurité n'a pas été effectué.
0 fichiers correctement traités ; échec du traitement de 1 fichiers
Messages postés
3035
Date d'inscription
vendredi 18 juin 2004
Statut
Contributeur
Dernière intervention
29 novembre 2021
427 >
Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018

Le système utilisé est en français, les commandes sont faites pour un compte de service noté en anglais ;-)
Il faut traduire dans les commandes le nom "Network Service" par "Service Réseau".
ça risque de coincer en ligne de commande en langue FR à cause des accents .... (d'où ma préférence pour la langue anglaise sur les serveurs entre autre ...)

Il faudrait passer par son SID S-1-5-20 :

ICACLS "%SystemDrive%\Windows\System32\inetsrv\config" /Grant *S-1-5-20:R /T


-

Sinon il faut faire les modifs à la main :-)
Messages postés
1380
Date d'inscription
samedi 13 juin 2009
Statut
Membre
Dernière intervention
23 août 2018
155
Il faudrait passer par son SID S-1-5-20 :

ICACLS "%SystemDrive%\Windows\System32\inetsrv\config" /Grant *S-1-5-20:R /T


Salut, je viens de reprendre mon serveur en le mettant sous Windows Server 2008.

J'ai exécuter la commande et j'ai obtenus ceci:

C:\Windows\System32>ICACLS "%SystemDrive%\Windows\System32\inetsrv\config" /Grant *S-1-5-20:R /T
fichier traité : C:\Windows\System32\inetsrv\config
fichier traité : C:\Windows\System32\inetsrv\config\administration.config
fichier traité : C:\Windows\System32\inetsrv\config\applicationHost.config
fichier traité : C:\Windows\System32\inetsrv\config\Export
fichier traité : C:\Windows\System32\inetsrv\config\redirection.config
C:\Windows\System32\inetsrv\config\schema: Accès refusé.
5 fichiers correctement traités ; échec du traitement de 1 fichiers