Formule de calcul avec #N/A

[Fermé]
Signaler
-
 ludi87 -
Bonjour,

J'ai plusieurs lignes avec des code articles et plusieurs colonnes qui correspondents à un fabricants (exemple colonne A : fabricant dupont, colonne B fabricant dupuis etc)
suite à une recherche V qui ne trouve pas de résultat, j'ai pour chaque ligne dans toutes les colonnes #N/A qui apparait sauf dans une colonne car excel a trouvé le code fabricant (correspondant à mon code article finalement)
j'aimerais inséréer une colonne supplémentaire avec une fomule = SI (N/A alors prendre cellule ou apparait le code)
je ne sais pas si cela est possible
j'ai essayé de remplacer les #N/A par un chiffre ou une lettre pour faciliter la formule mais excel ne reconnait pas le #N/A

merci beaucoup pour votre aide

2 réponses

Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 090
Bonjour

En principe, il y a moyen de trouver une valeur dans un tableau à partir d'une liste de code dans une colonne et des noms de fabricants en ligne 1, mais, là,
vous devriez déposer un modèle de votre fichier pour qu'on comprenne un peu mieux. On ne voit pas où sont vos codes et ce que vous cherchez à ressortir en fonction de quoi?

voyez pour déposer sur:
https://www.cjoint.com/
avec quelques explications dans le fichier, et revenez ici coller le lien donné par le site (création du lien en bas de la page de dépôt, le lien s'affiche en haut)

à vous lire

crdlmnt

je vous remercie
voici le lien
http://www.cjoint.com/c/ELekReUmOM0
il s'agit d'un fichier jumeau car le vrai est confidentiel
en colonne B en rouge c'est là ou je dois mettre la formule
bien sur le vrai fichier a 400 lignes et 15 colonnes
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 090
Excel ne travaille pas s'il rencontre ce type de code avec # dans une ligne.

Pouvez vous modifier dans votre tableau de base la formule qui affiche ce fameux résultat, par exemple avec ce code valable pour Excel à partir de 2007:

=SIERREUR(formule);"NA")

vous pourriez alors utiliser sous réserve d'avoir une seul code sur chaque ligne, et que votre code soit bien numérique:
=MAX(C2:E2)

crdlmnt
Bonjour je vous remercie
mais je ne comprends pas la formule à indiquer dans =SIERREUR(formule);"NA")
Messages postés
24202
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 937
Bonjour,

ou bien :
=MAX(SI(ESTERREUR(C2:E2);0;C2:E2)) 

formule matricielle à valider avec shift+ctrl+entrée
La formule doit s'entourer de { } si la validation est correcte.
eric
je vous remercie
mais le chiffre "0" sur toute la colonne apparait donc la formule ne fonctionne pas.
le fait de la valider avec shift+ctrl+entrée ne change rien.
j'essaie de remplacer le "0" par "valeurnombre" mais excel n'accepte pas
je vous remercie quand même
je vous remercie mais cela ne fonctionne pas.
le "0" apparait sur toute ma colonne de résultat.
j'ai essayé de remplacerl le 0 dans votre formule par "valeurnombre" mais cela ne fonctionne pas.