Probleme avec php 5.5 sur debian 7 [Résolu/Fermé]

Signaler
-
Messages postés
29904
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 juin 2021
-
Bonjour,

Je n'arrive pas a installer la dernière version de GLPI visiblement a cause de PHP 5.5.
J'ai tente une reinstalle mais rien y fait

ci dessous le resultat quand j'attaque l'@ web glpi

 -------------------------------------------------------------------------- */ // ---------------------------------------------------------------------- // Original Author of file: // Purpose of file: // ---------------------------------------------------------------------- define('DO_NOT_CHECK_HTTP_REFERER', 1); // If config_db doesn't exist -> start installation define('GLPI_ROOT', '.'); include (GLPI_ROOT . "/config/based_config.php"); if (!file_exists(GLPI_CONFIG_DIR . "/config_db.php")) { include_once (GLPI_ROOT . "/inc/autoload.function.php"); Html::redirect("install/install.php"); die(); } else { $TRY_OLD_CONFIG_FIRST = true; include (GLPI_ROOT . "/inc/includes.php"); $_SESSION["glpicookietest"] = 'testcookie'; // For compatibility reason if (isset($_GET["noCAS"])) { $_GET["noAUTO"] = $_GET["noCAS"]; } Auth::checkAlternateAuthSystems(true, isset($_GET["redirect"])?$_GET["redirect"]:""); // Send UTF8 Headers header("Content-Type: text/html; charset=UTF-8"); // Start the page echo ''."\n"; echo ''; echo ''."\n"; echo ''."\n"; echo ''."\n"; echo ''; // Appel CSS echo ''; // surcharge CSS hack for IE echo ""; echo ""; echo ""; echo ""; echo "
"; echo "
"; echo nl2br(Toolbox::unclean_html_cross_side_scripting_deep($CFG_GLPI['text_login'])); echo "
"; echo "
"; echo "
"; // Other CAS if (isset($_GET["noAUTO"])) { echo ""; } // redirect to ticket if (isset($_GET["redirect"])) { Toolbox::manageRedirect($_GET["redirect"]); echo ''; } echo "
"; echo '
'.$LANG['login'][10].'
'; echo '
'.$LANG['login'][6].' : '; echo ''; echo '
'; echo '
'.$LANG['login'][7].' : '; echo ''; echo '
'; echo "
"; echo '

'; echo '

'; echo '
'; Html::closeForm(); echo ""; echo "
"; // end login box echo "
"; echo ""; if (isset($_GET['error'])) { switch ($_GET['error']) { case 1 : // cookie error echo $LANG['login'][27]; break; case 2 : // GLPI_SESSION_DIR not writable echo $LANG['install'][50]." : ".GLPI_SESSION_DIR; break; } } echo "
"; // Display FAQ is enable if ($CFG_GLPI["use_public_faq"]) { echo '
[ '.$LANG['knowbase'][24].' ]'; echo '
'; } if ($CFG_GLPI["use_mailing"] && countElementsInTable('glpi_notifications', "`itemtype`='User' AND `event`='passwordforget' AND `is_active`=1")) { echo '
[ '.$LANG['users'][3].' ]'; echo '
'; } echo "
"; // end contenu login if (GLPI_DEMO_MODE) { echo "
"; Event::getCountLogin(); echo "
"; } echo "
"; echo ""; echo 'GLPI version '.(isset($CFG_GLPI["version"])?$CFG_GLPI["version"]:""). ' Copyright (C) 2003-'.date("Y").' INDEPNET Development Team.'; echo "
"; } // call cron if (!GLPI_DEMO_MODE) { CronTask::callCronForce(); } echo ""; ?>




Configaration Debian 7 wheezy

1 réponse

Messages postés
29904
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 juin 2021
7 125
Bonjour,

Le message n'est pas très clair.

Quand tu dis "j'attaque" ça veut dire "quand tu te connectes à ce site avec ton navigateur" ? Si oui j'imagine que ce que tu as copié collé est ce que tu vois apparaître dans ton navigateur ?

Si tel est le cas, c'est que php n'est pas installé ou activé au niveau du serveur web (qui j'imagine est la debian dont tu parles).

Dans ce cas tu peux te référer à cette page, qui décrit toute l'installation d'un serveur LAMP (Linux Apache Mysql PHP) :
https://www.mistra.fr/tutoriel-linux-serveur-web-apache2.html

En particulier tu verras qu'il faut installer un paquet (en root) :

apt-get update
apt-get inlibapache-mod-php5


... activer ce module :

a2enmod php5


... et relancer apache :

service apache2 restart


Bonne chance
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Merci pour le retour
Effectivement c'est le résultat de navigateur quand je tape l'@ il du serveur, oui il s'agit d'une déniant 7 wheezy.
En revanche je n'est pas active photo (oups) je test ça
Encore merci
Désolé pour le message précédant mais le correcteur du téléphone a fait des siennes.
Donc j'ai consulté le lien et appliqué votre procédure et par magie tout fonctionne, et je viens de controler effectivement a aucun moment je n'ai active PHP.
erreur de débutant.
encore merci, je clos le sujet
Messages postés
29904
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 juin 2021
7 125
Merci pour ton retour, bonne continuation !