Formule avec recherche dans plusieurs cellules

Fermé
FSgirl Messages postés 18 Date d'inscription dimanche 11 octobre 2015 Statut Membre Dernière intervention 28 novembre 2015 - 11 oct. 2015 à 04:23
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 - 11 oct. 2015 à 09:24
Bonjour,

J'ai 2 cellules A6 et A11 qui contient du texte
et je voudrais faire une référence avec une autre cellule Y18 qui contient aussi du texte
Je voudrais une formule en A15 avec ces conditions :
- si dans la cellule $Y$17 se trouve le texte de A6 ou A11, alors A15=texte de la cellule $V$17,
- si dans la cellule $Y$18 se trouve le texte de A6 ou A11, alors A15=texte de la cellule $V$18,
- si dans la cellule $Y$19 se trouve le texte de A6 ou A11, alors A15=texte de la cellule $V$19,
- ETC
- sinon ""

Pouvez-vous m'aider à faire cette formule SVP ??

Merci


A voir également:

2 réponses

Raymond PENTIER Messages postés 58388 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 17 avril 2024 17 088
11 oct. 2015 à 06:54
Non : On ne peut pas travailler sérieusement avec ETC !
Ta formule doit contenir autant de tests que de cellules concernées en Y :
=SI(OU(Y17=A6;Y17=A11);v17; SI(OU(Y18=A6;Y18=A11);v18; SI(OU(Y19=A6;Y19=A11);v19; SI(OU(Y20=A6;Y20=A11);v20; ...
Donc tu dois indiquer combien il y en a ...
0
Raymond PENTIER Messages postés 58388 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 17 avril 2024 17 088
11 oct. 2015 à 06:57
... mais ton problème est très inhabituel : Pourrais-tu expliquer exactement de quoi il s'agit ? On pourra peut-être t'orienter sur une autre méthode de résolution.
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 394
Modifié par Vaucluse le 11/10/2015 à 09:25
Bonjour
pas sur d'avoir compris, essayez:

=SIERREUR(INDEX(V:V;EQUIV(SI(NB.SI(Y:Y;A6);A6;A11);Y:Y;0));"")

mais avec n'importe quelle solution vous n'aurez que la valeur de V sur la 1° ligne qui contiennent A6 ou A11

en complément, si vos textes en Y sont plus long qu'en A6 ou A11 et que vous voulez déterminer si ces textes contiennent ces valeurs:

=SIERREUR(INDEX(V:V;EQUIV(SI(NB.SI(Y:Y;"*"&A6&"*");"*"&A6&"*";"*"&A11&"*");Y:Y;0));"")

crdlmnt


Errare humanum est, perseverare diabolicum
0