Incrémenter et revenir à zero colonne excel

[Fermé]
Signaler
Messages postés
1
Date d'inscription
dimanche 27 septembre 2015
Statut
Membre
Dernière intervention
27 septembre 2015
-
Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
-
Bonjour,
Je souhaite incrémenter une colonne puis revenir à zero dans un cas précis (mon exemple 539+000, 539+010 ... 539+1000 540+000, 540+010, 540+020 ... 540+1000 541+000, 541+010 ...). Existe il une formule ou macro sur excel pour faire cela ?
Merci d'avance

3 réponses

Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
16 744
Bonjour.

Tout d'abord, peux-tu nous confirmer que dans ta liste on passe bien de 1529 à 1539 puis à 540, 550 etc ? Cela me semble bizarre ...
Messages postés
10146
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
13 octobre 2021
2 230
Bonjour à tous les deux

Si je m'en tiens strictement à ta demande (mais pas sûr d'avoir bien compris)
A1=539+000
A2=SI(CNUM(DROITE(A1;NBCAR(A1)-TROUVE("+";A1;1)))<990;GAUCHE(A1;TROUVE("+";A1;1)-1)&"+"&TEXTE(CNUM(DROITE(A1;NBCAR(A1)-TROUVE("+";A1;1)))+10;"000");CNUM(GAUCHE(A1;TROUVE("+";A1;1)-1)+1) & "+000")

Cdlmnt
Bonjour,
Merci ccm81 pour votre réponse. Malgré tout une erreur persiste lorsque je passe de 539+990 à 540+000 le message d'erreur '#valeur!' apparaît. Comment faire pour y remédier ? Cdlmt
Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
16 744
Tu as fait une erreur quelque part : La formule de ccm81 marche très bien ...
https://www.cjoint.com/c/EICwKeHqkim