Gestion de production, ordonnancement et stock avec Excel [Fermé]

Signaler
Messages postés
4
Date d'inscription
mercredi 9 septembre 2015
Statut
Membre
Dernière intervention
10 septembre 2015
-
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
-
Bonjour les amis,
Pour la petite histoire, je suis actuellement en stage, je travaille dans l'industrie.
Un de mes challenge est de réaliser une gestion de production, avant de gérér tout cela, et commencer à prendre des décision sur par quel produit commencer, je dois savoir si j'ai toutes les pièces en stock pour réaliser ce dernier.
Pour faire plus simple, pour faire un produit A j'ai besoin des pièces 1 et 2 et 3. Si par exemple je n'ai pas la 2 je ne pourrais pas faire ce produit.
Ma question sur excel est, j'ai une colonne A sur excel avec les codes de toutes mes pièces, dans la colonne B j'ai la quantité de chaque pièces. Pour le reste ,j'ai dans chaque colonne un type de produit, avec les quantités de chaque pièce nécéssaire pour le réaliser.
Excel peux-t-il me dire, pour le produit D, vu que tu as besoin de 10 de la pièce 1, 20 de la pièce 2 et 30 de la pièces , et vu qu'en stock tu n'ai que 28 de la pièces 3, tu ne pourras pas réaliser ce type de produit, et le mettre en bleu quand je peux, et en rouge quand je ne peux pas.

Merci pour votre aide, et n'hésitez pas à me demander si besoin de plus d'informations.
A voir également:

2 réponses

Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Bonjour
l formule où vous voulez pour dire possible ou pas possible
en A les codes produits (code1,code2,code3 ect)
en B la quantité de produits disponibles pour chaque code

La formule pour savoir si vous pouvez construire le produit en E1

=SI(ET(RECHERCHEV(Code1;A:B;2;0)<10;RECHERCHEV(Code2;A:B;2;0)<20;RECHERCHEV(Code3;A:B;2;0)<30));"non";"OK")

et ur la mise en forme
mise en forme conditionnelle/ Régle / utiliser une formule:

=$E1="non" formatez en rouge
=$E1="OK" formatez en vert

vous pouvez aussi placer en D1 le nom du produit
en dessous en D2,D3,D4 la liste des codes produits nécessaires et en ligne en E les quantités nécessaires pour le produit D1
en F2:
=RECHERCHEV(E2;A:B;2;0) vous donnera le nombre de produits disponibles
(à tirer sur la hauteur de la liste)

et la formule de MFC deviendra:
=F2>=E2 pour vert
=F2<2 pour rouge

crdlmnt




Errare humanum est, perseverare diabolicum
Messages postés
4
Date d'inscription
mercredi 9 septembre 2015
Statut
Membre
Dernière intervention
10 septembre 2015

Merci pour votre réponse Vaucluse, mais après essai ceci n'est pas exactement ce dont j'ai besoin.
je vais essayer d'être plus précis dans ce message.

Colonnes:
- A : code article
-B : quantité article en stock
-C-D-E : produit C produit D et produit E

Sachant que pour faire un produit j'ai besoin de plusieurs articles, dans les lignes j'ai :
1: nom des colonnes
A2: premier code article
B2: qté article en stock
C2: combien de cet article j'ai besoin pour faire le produit A
D2: combien de cet article j'ai besoin pour faire le produit B
ainsi de suite.

Sachant que j'ai besoin de plus de 20 articles (minimum) pour faire un produit, il me faut en fait en bas de la colonnes C par exemple, si tout les articles nécéssaires sont bien en stock, si oui, feu vert pour commencer l'assemblage ou la construction.

Merci encore une fois.
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Bonjour
alors pour éviter la prospecter au hasard et de proposer des solutions au hasard si possible, placer un modèle, (même avec des noms bidonnés si besoin e confidentialité), le plus complet possible sur
http:/www.cjoint.com
avec quelques explications et revenez ici coller le lien donné par le site.
à vous lire
crdlmnt
Messages postés
4
Date d'inscription
mercredi 9 septembre 2015
Statut
Membre
Dernière intervention
10 septembre 2015

Salut Vaucluse,
Comme demandé : http://www.cjoint.com/c/EIkgMx32IZT
Merci pour votre aide.
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Re
voila ce que ça pourrait donner mais c'est sous toutes réserves vu le manque d'information
https://www.cjoint.com/c/EIkiYDxPVur
les colonnes où le nombre d'éléments devient insuffisant s'allument" en orange et la commande ne peut pas être réalisées et la colonne H donne les noms, des clients concernés, mais sous réserve que les commandes soient bien effectuées dans l'ordre où les clients sont placés en ligne 1, sinon Excel ne peut pas deviner
par ailleurs,
Si jamais vous avez un nombre plus important de client, la mise en forme en orange pourra toujours être mis en place (revenez si besoin sur ce sujet avec le nombre de colonnes à équiper), mais la liste de la colonne H, elle ne pourra pas être éditée facilement
dans tous les cas, chaque fois qu'un ligne contient une cellule Orange, la commande correspondante ne peut pas être réalisée;
Crdlmnt
Messages postés
4
Date d'inscription
mercredi 9 septembre 2015
Statut
Membre
Dernière intervention
10 septembre 2015

Merci beaucoup vaulcluse, c'est déjà excellent.
COmme vous le dites, le seul "hic", c'est l'ordre des clients, en d'autres termes, Excel ne peut pas réfléchir et dire puisque cette commande a tout les composants sauf le composant x, et que le x est alloué pour une autre commande, autant l'allouer a cette première commande comme ça elle est prête.

Pour les autres colonnes, vu que j'en ai environs une cinquantaine, je dupliquerais le code en "SI", je pense avoir compris à peu près la fonction que vous avez rédigés.

Merci beaucoup en tout cas.
Très cordialement.
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
En se creusant un peu, on devrait pouvoir ordonner les commandes selon d'éventuelles dates de livraison.
Info: pour la MFC en orange, il faut placer colonne par colonne avec la somme depuis le début jusqu'à la colonne.