Planning restauration [Fermé]

Signaler
Messages postés
2
Date d'inscription
dimanche 6 avril 2014
Statut
Membre
Dernière intervention
8 septembre 2015
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour à tous,

J'ai hélas un problème pour compté les heures hebdomadaire dans le planning que je créer actuellement, je m'explique :

Chaque jour fonctionne sur quatre cellule, exemple C21:D21 pour le matin et C22:D22 pour l'après-midi, le soucis donc que lorsque la personne ne travail pas le matin je met dans les cellules C21:D21 un slash (/) et l'après-midi les horaires et inversement quand la personne travail l'après-midi et pas le matin. Mais comme il y en a toujours un, lorsque que celui-ci est en repos toute la journée, je met RH dans les quatre cellules, pour rappel C21:D21 et C22:D22, du coup lorsque je met ma case total O21:O22 (case fusionné) à la fin de la semaine pour faire le calcul, il est normal que je me retrouve avec une valeur en erreur #### vu que j'ai des mots avec des chiffres.

Du coup, d'ou ma question, qu'elle fonction dois-je utilisé afin de réussir mon calcul afin de transformer RH et / en chiffre 0 .

Ma fonction actuel pour le total est actuellement la suivante :

=SOMME(((D21-C21)+(D22-C22))+((F21-E21)+(F22-E22))+((H21-G21)+(H22-G22))+((J21-I21)+(J22-I22))+((L21-K21)+(L22-K22))+((N21-M21)+(N22-M22)))

Voici également mon fichier excel :

http://www.cjoint.com/c/EIiuB57RIL4

Cordialement.

Tob3rya

2 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 408
Bonjour,

Tu as un peu compliqué ton classeur alors il faut compliquer un peu ta formule :
=SOMME(SI(ESTNUM(D21);(D21-C21))+SI(ESTNUM(D22);(D22-C22))+SI(ESTNUM(F21);(F21-E21))+SI(ESTNUM(F22);(F22-E22))+SI(ESTNUM(H21);(H21-G21))+SI(ESTNUM(H22);(H22-G22))+SI(ESTNUM(J21);(J21-I21))+SI(ESTNUM(J22);(J22-I22))+SI(ESTNUM(L21);(L21-K21))+SI(ESTNUM(L22);(L22-K22))+SI(ESTNUM(N21);(N21-M21))+SI(ESTNUM(N22);(N22-M22)))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
dimanche 6 avril 2014
Statut
Membre
Dernière intervention
8 septembre 2015

Bonsoir gbinforme,

Tu viens de me retirer une grande épine dans le pied et je t'en remercie fortement, j'aurais une seconde question à te poser du coup, les plages horaires comprises entre 7h30 du matin et dépassant 12h00 octroie une pause d'une demi-heure et idem le soir entre 12h30 et 22h30, peut-on dans ce cas retirer un demi-heure chaque fois qu'une telle plage horaire est mis en place ou cela est il plus simple de retirer par exemple 2H30 directement à la main ?

Cordialement.
Tob3rya
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 408
Bonjour Tob3rya,

Voici ton classeur avec le calcul de la pause soustraite du total :

https://www.cjoint.com/c/EIjf22pyiwy